BIS blower problem

Admiral Posted By Admiral, Nov 28, 2013 at 9:02 AM

Thread Status:
Not open for further replies.
  1. Admiral

    Admiral
    New Member 2.
    NULL
    

    Nov 27, 2013
    2
    0
    Loc:
    New Hampshire
    The fan blower on my Bis Tradition just hums when the heat activates it. I have turned it off with the rotary control. I opened the front of it and ensured the blades weren't bound up and sprayed WD 40 on the shaft ends. Still no luck. Just wondering if anybody have any ideas on what the fix might be.
     
  2. xtrordinair

    xtrordinair
    Member 2.
    NULL
    

    Dec 28, 2012
    232
    55
    Loc:
    southern indiana
    the fan motor should be able to be spun by hand and keep spinning with little resistance.If it does try by passing the speed control to insure you dont have a issue there first before you condem the motor
     
  3. Admiral

    Admiral
    New Member 2.
    NULL
    

    Nov 27, 2013
    2
    0
    Loc:
    New Hampshire
    I can spin it by hand but it doesn't keep spinning after I take my hand away. It doesn't spin easily even when I use my hand. I plan to take it out this weekend and give it a more thorough look. Fire is going now so its inaccessible.
     
  4. begreen

    begreen
    Mooderator 2.
    NULL
    
    Staff Member

    Nov 18, 2005
    61,820
    7,901
    Loc:
    South Puget Sound, WA
    Remove and clean the blower and vacuum out the blower plenum. If the blower still has problems it could be a failed motor control.
     
Thread Status:
Not open for further replies.

Share This Page