Control box issue with Castile Quardra-Fire.

ne6359 Posted By ne6359, Sep 7, 2008 at 3:19 AM

Thread Status:
Not open for further replies.
  1. ne6359

    ne6359
    New Member 2.
    NULL
    

    Sep 7, 2008
    1
    0
    Loc:
    wisconsin
    I have a six year old Castile . This stove has been nothing but a big headache from the day it was installed. The control box was replaced under warranty within the first month, erratic ignition. Within the first year a new style auger, new number two snap disk. I clean the convection blower twice a year but it makes so much noise you can not sit in the room and hear the tv.

    This fall after a very complete cleaning and first fire for the season I have a problem with the exhaust blower. It will come on when first plugged in. When I turn the thermostat up , the call light comes on, pellets feed, fire starts and everything is working great. When the stove shuts down the exhaust blower never stops. My question being, does this sound like a malfunction control box? All lights work as the manual says they should. If I do need to replace the control box does anyone know of a cheaper source then $240.00

    Thanks for letting a newbie to the forums vent. I would be very very hard pressed purchase another Quadra-fire product or recommend one to anyone else.
     
  2. ms&c

    ms&c
    New Member 2.
    NULL
    

    Sep 11, 2008
    4
    0
    Loc:
    southern Maine
    The snap disk that turns the blower on also turns the blower off .just replace it .it is not reseting when it cools
     
Thread Status:
Not open for further replies.

Share This Page