1. Welcome Hearth.com Guests and Visitors - Please enjoy our forums!
    Hearth.com GOLD Sponsors who help bring the site content to you:
    Hearthstone Soapstone and Cast-Iron stoves( Wood, Gas or Pellet Stoves and Inserts)
    Caluwe - Passion for Fire and Water ( Pellet and Wood Hydronic and Space Heating)

Convection fan issue on m55...weird...

Post in 'The Pellet Mill - Pellet and Multifuel Stoves' started by Cleetussnow, Feb 8, 2013.

  1. Cleetussnow

    Cleetussnow Member

    Joined:
    Oct 3, 2012
    Messages:
    148
    Loc:
    Westchester, ny
    Hi all

    I wake this morning and the stove is on shut down mode. House is a little chilly. Sure enough the high temperature switch is tripped. So I reset and restart the stove, but the fan does not kick on. No problem, I change the fuse, and I start the stove up.

    Now the problems begin: When the stove gets warm, the fan kicks on, but starts cycling between high and low speeds at about a 2 or 3 second interval. I played with the heat settings, but on every setting, it did the same thing. Fan n high, then on a low, then high. Weird. I figure the mother board is dead, something like That maybe is blew the fuse to begin with.

    If anyone has experienced such a thing, I'd be interested to know. Dealer is coming next week, so he says, but he ought to have a new mother board in his hands when he gets here. The thing is under warranty.

    Helpful Sponsor Ads!





  2. imacman

    imacman Guest

    The stove was hooked to a good quality surge protector?
  3. Cleetussnow

    Cleetussnow Member

    Joined:
    Oct 3, 2012
    Messages:
    148
    Loc:
    Westchester, ny
    Yes it is a really good one actually.

Share This Page