I'm new and Dumb...

Post in 'The Pellet Mill - Pellet and Multifuel Stoves' started by Tenpounder, Oct 2, 2012.

  1. Brokenwing

    Brokenwing
    Expand Collapse
    Feeling the Heat

    Joined:
    Feb 11, 2012
    Messages:
    448
    Likes Received:
    139
    Loc:
    Northern Maryland
    Being that I have the regency gc60 i would love to hear what problems you have had with the m55. I am not running yet due to chasing smoke smell, and replacing pipe. Problem still may be with the stove so I would love to hear your opionion if you dont mind.
     
    Collapse Signature Expand Signature

    Helpful Sponsor Ads!





  2. jtakeman

    jtakeman
    Expand Collapse
    Minister of Fire

    Joined:
    Dec 30, 2008
    Messages:
    13,496
    Likes Received:
    1,571
    Loc:
    Northwestern CT.
    I remember a thread or two on the smoke smell. I found one(think there was another one somewhere). Check link.

    http://www.hearth.com/talk/threads/smelling-smoke-from-my-enviro-m55-cast.73811/#post-934029

    It should be checked out while the dealer(i'm assuming the dealer is doing the repair) is replacing the pipe. Seems some didn't get sealed properly and leaks at the adapter connection. Keep us posted!
     
    Collapse Signature Expand Signature
  3. FyreBug

    FyreBug
    Expand Collapse
    Minister of Fire

    Joined:
    Oct 6, 2010
    Messages:
    771
    Likes Received:
    145
    Loc:
    Kitchener, Ontario
    Well... I am old and dumb but you don't hear me braggin'....

    Sorry.. couldn't resist ;lol
     
    Collapse Signature Expand Signature
    jtakeman likes this.

Share This Page

Entire Site copyright © 1995-2016 - email to webinfo@hearth.com
Hearth.com and HearthNet are property and trademarks of Hearth.com LLC Advertising Information