1. Welcome Hearth.com Guests and Visitors - Please enjoy our forums!
    Hearth.com GOLD Sponsors who help bring the site content to you:
    Hearthstone Soapstone and Cast-Iron stoves( Wood, Gas or Pellet Stoves and Inserts)
    Caluwe - Passion for Fire and Water ( Pellet and Wood Hydronic and Space Heating)

p5105 Aquastat, Aquatemp sensor question

Post in 'The Boiler Room - Wood Boilers and Furnaces' started by Greg K., Nov 24, 2013.

  1. Greg K.

    Greg K. New Member

    Joined:
    Nov 24, 2013
    Messages:
    2
    Loc:
    Pennsylvania
    Does anyone have a picture of the PB105 aquastat sensor? Recently I installed a PB105 and was missing various parts. Its 20 degrees outside and I want to run the PB105 but I don't think I have the aquastat sensor. It appears I have the cable that plugs directly under the hopper that should attach to the sensor in the well, but I don't have a sensor that sits in the well?? Can anyone help me out here? Should there actually be a thermocouple on the end or is it just that cable with the molded heat shrink on the end? I searched the forums but no one else seems to have had this question. Thanks for the help!

    Helpful Sponsor Ads!





  2. Greg K.

    Greg K. New Member

    Joined:
    Nov 24, 2013
    Messages:
    2
    Loc:
    Pennsylvania
    In case anyone else is curious about this question, the aquastat sensor does not have a typical thermocouple at the end like the Exhaust probe. The end of the sensor is like a rubber heat shrink piece. That heat shrink piece sits in the bottom of the well.

Share This Page