1. Welcome Hearth.com Guests and Visitors - Please enjoy our forums!
    Hearth.com GOLD Sponsors who help bring the site content to you:
    Hearthstone Soapstone and Cast-Iron stoves( Wood, Gas or Pellet Stoves and Inserts)

Problem with pilot lite?

Post in 'It's a Gas!' started by jwicki, Nov 12, 2009.

Thread Status:
Not open for further replies.
  1. jwicki

    jwicki New Member

    Joined:
    Nov 12, 2009
    Messages:
    6
    Loc:
    Central New York
    I'm trying to re lite my propane stove. Its a heat and glo. When I attempt to lite the pilot it not cliking as it usually does. There is not spark. It has been workinging fine for the last few weeks?

    Any ideas?

    Helpful Sponsor Ads!





  2. DAKSY

    DAKSY Patriot Guard Rider Staff Member

    Joined:
    Dec 2, 2008
    Messages:
    5,294
    Loc:
    Averill Park, NY, on Burden Lake II...
    Is there power to the unit?
    What model is it?
    Plug something - a lamp, fan - some kind of small
    appliance into the receptacle underneath, if there IS one...
    If not, is there a battery powered igniter?
    Again, what model is it?
  3. jtp10181

    jtp10181 Minister of Fire

    Joined:
    Feb 26, 2007
    Messages:
    3,724
    Loc:
    Madison, WI
    What does the ignitor button look like, is it a round red or black button (not the on/off/pilot) and when you push it in there is some resistance to it?

    The other style runs off a 9v battery and I think automatically sparks when you hold in the pilot knob on the valve. Battery could be dead.
  4. Fsappo

    Fsappo Minister of Fire

    Joined:
    Apr 9, 2008
    Messages:
    3,868
    Loc:
    Central NY
    What did your dealer say?
  5. jwicki

    jwicki New Member

    Joined:
    Nov 12, 2009
    Messages:
    6
    Loc:
    Central New York
    The Model is Heat and Glo.
  6. jwicki

    jwicki New Member

    Joined:
    Nov 12, 2009
    Messages:
    6
    Loc:
    Central New York
    ****
    there is power. Heat and Glo. It is not a battery igniter.
  7. jwicki

    jwicki New Member

    Joined:
    Nov 12, 2009
    Messages:
    6
    Loc:
    Central New York
    ************
    Black one. no resistance. Just no spark. there is power to the unit?
  8. DAKSY

    DAKSY Patriot Guard Rider Staff Member

    Joined:
    Dec 2, 2008
    Messages:
    5,294
    Loc:
    Averill Park, NY, on Burden Lake II...
    Heat n Glo is NOT a model. It's a manufacturer of gas fireplaces & stoves
    (& other hearth units, as well).
    Is your unit a fire place?
    If it is, there's a silver sticker on the bottom right of the
    base of the unit - in the valve cavity.
    What MODEL is it?
  9. jwicki

    jwicki New Member

    Joined:
    Nov 12, 2009
    Messages:
    6
    Loc:
    Central New York
    Oh. Sorry. The model is Tiara 1
  10. DAKSY

    DAKSY Patriot Guard Rider Staff Member

    Joined:
    Dec 2, 2008
    Messages:
    5,294
    Loc:
    Averill Park, NY, on Burden Lake II...
    Is there a click when you push the button on the piezo??
    If there isn't, replace the piezo.
    If the IS, check to see if the wire coming out of the back
    of the piezo & that the wire sheathing is in good shape,
    i.e. - no bare spots where it could be grounding out & directing the
    spark to a spot other than the igniter near the pilot hood...
  11. jwicki

    jwicki New Member

    Joined:
    Nov 12, 2009
    Messages:
    6
    Loc:
    Central New York
    Is the Piezo under the stove for by the Pilot dial?
  12. jtp10181

    jtp10181 Minister of Fire

    Joined:
    Feb 26, 2007
    Messages:
    3,724
    Loc:
    Madison, WI
    http://heatnglo.com/customerCare/pilot.asp

    That is for a fireplace, yours has the same kind of components, just maybe not in the exact same locations.

    If you cannot figure it out after looking through that, you should have someone come service it for you.
Thread Status:
Not open for further replies.

Share This Page