1. Welcome Hearth.com Guests and Visitors - Please enjoy our forums!
    Hearth.com GOLD Sponsors who help bring the site content to you:
    Hearthstone Soapstone and Cast-Iron stoves( Wood, Gas or Pellet Stoves and Inserts)

Question about optimal operation of Enviro Empress insert

Post in 'The Pellet Mill - Pellet and Multifuel Stoves' started by nanama72, Oct 23, 2008.

Thread Status:
Not open for further replies.
  1. nanama72

    nanama72 Member

    Joined:
    Mar 9, 2008
    Messages:
    101
    Loc:
    Western MA
    We have not tried using the thermostat with it yet because every time we change the level which adjusts the rate of the auger, we have to adjust the amount of air going into the flame to get an efficient burn. There's no way we could use the on off setting because it takes a while to restart. After cleaning, we put in a handful of pellets and put it on high but it still takes a while to get burning with a flame after smoldering for some time.. Should the damper be all the way open when starting? Depending on the pellets, some we can use with the damper midway open but others we have to close it almost all the way down. What would be the best for starting it up efficiently? Has anyone gotten the automatic thermostat to work well with it without just smoldering when it turns down?

    Helpful Sponsor Ads!





  2. nanama72

    nanama72 Member

    Joined:
    Mar 9, 2008
    Messages:
    101
    Loc:
    Western MA
    Does anyone know why I can't get it to run on the low settings? I've only been burning it for one week and it's brand new and was professionally installed. All the empress insert does on low settings is smolder.
  3. 90durham

    90durham New Member

    Joined:
    Jul 18, 2008
    Messages:
    53
    Loc:
    Southeast Ontario
    I have the FS and have needed to adjust the damper after the initial install due to switching to a different brand of fuel from what the installers used to do set up.
    Spoke to dealer yesterday when picking up pellets and he said a minor adjustment may be needed based on fuel quality. My son found the the damper rod and it's taken me about a week to get the correct setting again, I haven't used the #1 or #2 setting as I was seeing the same thing as you.
  4. smithmal

    smithmal New Member

    Joined:
    Nov 5, 2007
    Messages:
    7
    Loc:
    MD
    I'm using an Empress as well and my install guy indicated that the low setting is "too low to be effective" (i.e. the auger's rate doesn't allow for a sustainable flame). I don't use the thermostat though (installer indicated they weren't really ready for primetime yet).

    smithmal
  5. Obie25

    Obie25 New Member

    Joined:
    Sep 1, 2008
    Messages:
    33
    Loc:
    Central CT
    I have the empress fire place insert! Glad to hear that other people do to. Frankly I struggled the first couple of times trying to get the stove started and keeping it going. But now that I've got my stove figured out its been running just about 24/7 except the times for shut down and cleaning.

    I found that this works well for me.

    1. Put a couple of handful of pellets in the fire box
    2. Set the stove to the highest setting (5)
    3. Adjust the damper to get a good flame
    4. After a few minutes set it down to three (3)
    5. Adjust the damper for three to maintain a good flame <---- by good flame..means it cycles...low flame just barely sneaking outta the fire box to a good healthy flame
    6. I think my damper is pretty close to all the way closed

    I find that ..this system works for me everytime I do the start up.
Thread Status:
Not open for further replies.

Share This Page