1. Welcome Hearth.com Guests and Visitors - Please enjoy our forums!
    Hearth.com GOLD Sponsors who help bring the site content to you:
    Hearthstone Soapstone and Cast-Iron stoves( Wood, Gas or Pellet Stoves and Inserts)

Question.. Convection blower for Avalon Newport stove starts then stops

Post in 'The Pellet Mill - Pellet and Multifuel Stoves' started by Timothy129, Jan 12, 2013.

  1. Timothy129

    Timothy129 New Member

    Joined:
    Jan 12, 2013
    Messages:
    3
    I have had stove for 5 years, this is first year I have had trouble. The stove starts up fine everything in working order. The convection blower comes on fine, but after 10-15 mins. The convection blower starts to turn more slowly. If I try to lower fan speed the fan will basically stop moving, but is trying to spin. Turning it to a higher setting doesn't do anything. I have replaced convection blower, control panel, and system snap disc. Still having same problem. Any help would be appreciated.

    Helpful Sponsor Ads!





  2. CtPaul

    CtPaul Burning Hunk

    Joined:
    Sep 16, 2011
    Messages:
    139
    Loc:
    CT
    Heat related maybe?
  3. SmokeyTheBear

    SmokeyTheBear Minister of Fire

    Joined:
    Nov 10, 2008
    Messages:
    12,536
    Loc:
    Standish, ME
    Have those convection blowers ever been oiled (that is if they can be oiled)?

    Has the convection air path been cleaned (it starts at the stove shell where air is allowed inside the shell and ends outside the stove shell in front of the heat exchanger tubes)?
  4. Timothy129

    Timothy129 New Member

    Joined:
    Jan 12, 2013
    Messages:
    3
    I have cleaned air intake, I will try to clean exchanger tubes. Heat seams fine.
  5. SmokeyTheBear

    SmokeyTheBear Minister of Fire

    Joined:
    Nov 10, 2008
    Messages:
    12,536
    Loc:
    Standish, ME
    Have you oiled the convection blower (if it is oil-able) and have you cleaned its squirrel cage which is the blowers air intake?
  6. imacman

    imacman Guest

    The replacement was a new blower/motor unit?
  7. Timothy129

    Timothy129 New Member

    Joined:
    Jan 12, 2013
    Messages:
    3
    Thank you for your suggestions, turns out my blower was not mounted correctly. In my defense who knew? I appreciate the help.
  8. CtPaul

    CtPaul Burning Hunk

    Joined:
    Sep 16, 2011
    Messages:
    139
    Loc:
    CT
    Glad you figured it out! Now we all know to look for that :)

Share This Page