1. Welcome Hearth.com Guests and Visitors - Please enjoy our forums!
    Hearth.com GOLD Sponsors who help bring the site content to you:
    Hearthstone Soapstone and Cast-Iron stoves( Wood, Gas or Pellet Stoves and Inserts)

Whitfield advantage 2 pellet stove room blower turning off

Post in 'The Pellet Mill - Pellet and Multifuel Stoves' started by Stashmann, Feb 23, 2008.

Thread Status:
Not open for further replies.
  1. Stashmann

    Stashmann New Member

    Joined:
    Feb 23, 2008
    Messages:
    1
    Loc:
    upstate NY
    First off thanks to those that will help !
    Bought the stove used. Worked great for 2 weeks. The room blower then started to shut off while the feed auger and the combustion blower keep working. The room blower will then tun on after a while and then go off again. The stove is not hooked to a seperate thermostat and I think that the room blower should not shut off. The stove then shut itself down a few times (I think on overtemp) because of the room blower not working possibly. The wiring diagram I have looks to be that if the high limit switch trips it will also kill the auger, this does not happen. The combustion blower turns off after cool down so I dont think it is the vacuam switch as that would make all blowers run after shutdown. I did some research online and could not find a problem like mine. I know how to use a multimeter and any help woud be great.
    Thanks
    Stashmann

    Helpful Sponsor Ads!





  2. drtnshtr

    drtnshtr New Member

    Joined:
    Jan 26, 2008
    Messages:
    204
    Loc:
    Ohio
    I would call and ask for mike.1-800-784-8377 he has all the whitfied info and parts you would ever need available and im sure he could help...
  3. hearthtools

    hearthtools Moderator Emeritus

    Joined:
    Jan 6, 2006
    Messages:
    2,019
    Loc:
    Oakhurst, California, USA, Earth
    Yes best to test the voltage and AMP draw of the motor when it is cold and after the motor has ran and heated up.

    Full on Voltage guide on the wire diagrams
    this is on my whitfield parts page linked near the control boards
    http://www.hearthtools.com/parts/replacement_parts_for__advantage.htm

    But it could be that the motor is going bad and heating up and the thermo protection build into the motor is shutting it off
  4. alex123

    alex123 New Member

    Joined:
    Oct 8, 2008
    Messages:
    3
    Loc:
    wa
    I have exact same issue.. Any resolve to this??
Thread Status:
Not open for further replies.

Share This Page