Whitfield Advantage II, Room blower problem

kc223 Posted By kc223, Jul 18, 2008 at 11:27 PM

Thread Status:
Not open for further replies.
  1. kc223

    kc223
    New Member 2.
    NULL
    

    Jul 18, 2008
    2
    0
    Loc:
    Roanoke, VA
    I replaced the room blower on a Whitfield Advantage II, insert, serial # 76708, but it still is acting like the motor is bad. When I turn the knob to adjust the air flow, it just quits, and then starts up slow and bogs down again. It will not run on medium or high speed. Even when knob is on low, fan is making a noise. Is this a control panel problem?
     
  2. Shane

    Shane
    Minister of Fire 2.
    NULL
    

    Nov 21, 2005
    1,831
    3
    Loc:
    Casper Wyoming
    Very well could be the board. Take an old extension cord and cut off the ends hook the blower to it and see how it runs.
     
  3. kc223

    kc223
    New Member 2.
    NULL
    

    Jul 18, 2008
    2
    0
    Loc:
    Roanoke, VA
    Thank you for the advice. Sure enough the old fan works fine when using the extension cord. So now I quess the search is on for a circuit board. Can circuit boards be fixed? If so, who would you contact?
     
  4. Shane

    Shane
    Minister of Fire 2.
    NULL
    

    Nov 21, 2005
    1,831
    3
    Loc:
    Casper Wyoming
    You might be able to get an electrical shop to fix it. But usually just buying the new board is the best route. Hearthtools sells them just look for his banner at the top of the pellet forum.
     
Thread Status:
Not open for further replies.

Share This Page