Whitfield Profile 20 Blowing Smoke and Sparks

Avgjoeshmoe Posted By Avgjoeshmoe, Oct 10, 2010 at 2:43 PM

Thread Status:
Not open for further replies.
  1. Avgjoeshmoe

    Avgjoeshmoe
    New Member 2.
    NULL
    

    Oct 10, 2010
    1
    0
    Loc:
    So NH
    Purchased a Profile 20 in 2000. Stove ran fir for the first two years. Ever since, nothing but problems. I clean the stove every 5 - 7 days. The Glass needs to be cleaned every day because of soot build up. Once a month, I do a full cleaning which includes full vacuuming of burn area, heat exchanger, motors, exhaust pipe etc... top to bottom.

    In years past we have always noticed a smoky smell during start up. Last year the smoky smell also occurs during normal operation.

    This season, after a full cleaning, firing it up I noticed sparks spewing out from the heat exchangers. Not from the pipes themselves but behind the louvers on the right hand side. The sparks were shooting 2 - 3 feet into the room!!!
    I'm trying to get the louvers off so I can look down and see what the problem is. Does not seem to be an easy way to do that... I'm open to suggestions.

    Has anyone else experienced this problem?

    After reading this message board I'm really surprised that no one has filed a class action suit against Lennox. After owning this stove I would not buy another Lennox product again!
     
  2. Wood Heat Stoves

    Wood Heat Stoves
    Minister of Fire 2.
    NULL
    

    Jun 12, 2009
    1,905
    14
    Loc:
    Nevada City, California
    sounds like you are missing some steps in the maint. division//
    shoot me a pm with your email for the svc book

    if it ran great for 2yrs, sounds like basic svc issues to me
     
Thread Status:
Not open for further replies.

Share This Page