Danson CC3 woodpellet heater - auger only works on feed rate #4 and trying to find/install the thermostat add-on module.

  • Active since 1995, Hearth.com is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.

Tunerbuilder

New Member
Feb 9, 2022
3
Great white north
I recently bought a house, and I have a danson cc3 wood pellet heater that is already installed in the garage. Heater has been used off and on since it was installed in 2003, but is in fairly decent shape and works quite well if left at feed rate 4

From what I can tell everything mechanically is in good working condition, but the feed auger only functions at feed rate number 4 or during cold startup. If I have the feed rate set to 1, 2, or 3 after its completed the warm-up cycle, the auger doesn't actually turn and the fire slowly dies out.

I haven't been able to find a lot online that's related to my problem, but from what I can tell it seems like a control board issue since everything works just fine when on feed rate 4.

Second question is about the optional thermostat control. From what I've read online, it requires an additional control board and a two wire thermostat. I've had zero luck finding an actual installation manual online, or even sourcing the parts all together.

If anyone has any idea or leads on where I can get new or used Accutron and thermostat control boards and a user manual for the stove/installation manual for the thermostat add-on I would greatly appreciate it.

16444570948867980524074804951003.jpg
 

Mt Bob

Minister of Fire
Oct 31, 2013
3,953
park county montana
Yep, sounds like control board issue. You may be able to get it repaired.And the manual in th elink provided explains installing a thermostat.