1. Welcome Hearth.com Guests and Visitors - Please enjoy our forums!
    Hearth.com GOLD Sponsors who help bring the site content to you:
    Hearthstone Soapstone and Cast-Iron stoves( Wood, Gas or Pellet Stoves and Inserts)

Anyone know how to test a snap disc?

Post in 'The Pellet Mill - Pellet and Multifuel Stoves' started by saladdin, Apr 23, 2012.

  1. saladdin

    saladdin Feeling the Heat

    Joined:
    Dec 29, 2011
    Messages:
    341
    Loc:
    West Tennessee
    Think I am having a snap disc problem on my cab50.

    Yes, it has been cleaned top to bottom.

    When I turn the stove on the fan comes on, the first drop of pellets fall, the ignitor lights them but then no more dropping of pellets. It's like something is telling it NOT to drop any more pellets. So, the single "dose" of pellets burn out and stove turns off.

    I hit the reset and it runs like a top. But if the stove ever cools down (doesn't run for say, for a day) and I start it up the same issue appears. it stops feeding after first batch of pellets.

    Anyone know what the range is for resistance (or anything else) that I can use to test the snap disc with a multimeter?

    Helpful Sponsor Ads!





  2. jtakeman

    jtakeman Minister of Fire

    Joined:
    Dec 30, 2008
    Messages:
    13,502
    Loc:
    Northwestern CT.
    I have used a heat gun, a temp probe and my meter to test the closing of the snap disc. The probe will tell you the temp it is when it finally closes. Hair dryer and a meter might work?
  3. tigerjeb

    tigerjeb New Member

    Joined:
    Nov 18, 2011
    Messages:
    14
    Loc:
    Lower Central Michigan
    I had a similar issue at the beginning of the season with the same model. I unplugged it and plugged it back in after about 15 minutes and cleaned the magnet area that tells the system that the lid is closed. I figured like any computer system, cutting the power might reset the board and it also turned out that I had filled the magnet area too full with pellets. I know it's not a perfect response, but maybe give that a shot also.
  4. DexterDay

    DexterDay Guest

    The snap disc wont stop the auger. IIRC

    I would look into a vacuum issue or proper placement of the thermocouple and the cover. Make sure the Thermocouple is touching the inside end of the ceramic cover and male sure the cover is sticking out over the end of the pot, the specified distance.

    After the initial feed of pellets, the stove waits to see temp from the T/C. At 200° it starts to feed (I think its 200°) then it gets another signal around 500°-600°…

    My money is on the T/C

    (Edit: the overtemp Snap disc will stop the auger. But this does not sound like that. Also it must be reset to refire)
  5. kinsmanstoves

    kinsmanstoves Minister of Fire

    Joined:
    Aug 29, 2007
    Messages:
    3,372
    Loc:
    Kinsman, Oh 44428 Brookfield, Oh 44403
    check door seal. latch the door and attempt to move it by grabbing the door. If it wiggles remove the nut on the back of the handle and watch for the key, it will fall out. remove the washer and place it between the cam latch and the nut. This will tighten the door and keep your negative pressure switch from tripping.

    What is happening is that you are not getting a good seal on the door. Once in a while it will make a good seal and run great. The other time it does not seal and after the initial start up the pressure switch will trip like it is suppose to do and keep the stove from feeding pellets.

    Eric
  6. saladdin

    saladdin Feeling the Heat

    Joined:
    Dec 29, 2011
    Messages:
    341
    Loc:
    West Tennessee
    Checked the door but it is snug and does not wiggle at all.
    kinsmanstoves likes this.
  7. DexterDay

    DexterDay Guest

    Did you check the thermocouple and cover? That tip has to be all the way at the end of the Ceramic cover. Touching the inside tip. Then the cover has to stick outinto the pot (so the flames can "lick" the cover).
  8. saladdin

    saladdin Feeling the Heat

    Joined:
    Dec 29, 2011
    Messages:
    341
    Loc:
    West Tennessee
    Thanks. I sure did. There was a "finger nail" size of ash inside the cover when I removed it. I pushed the coupler as far as possible before tightening it back down.
  9. tjnamtiw

    tjnamtiw Minister of Fire

    Joined:
    Mar 9, 2009
    Messages:
    4,052
    Loc:
    North Georgia
    Although the snap disc is most likely not the culprit, to answer your question set your multimeter to resistance (ohms). Unhook at least one of the leads on the snap disc and measure across the terminals. If the reading is zero ohms, the switch is closed. If the reading is very high in the megaohms range, then it is open. Now, of course, some snap discs are normally open (NO) and some are normally closed (NC), so you need to know which you are dealing with to know if the disc is bad or not.
  10. saladdin

    saladdin Feeling the Heat

    Joined:
    Dec 29, 2011
    Messages:
    341
    Loc:
    West Tennessee

    Thanks.

    The dealer is coming out to take a look at it. I'm leaning your way since everything I've read says that the odds of a snap disc going bad is pretty much nil.

    Something is telling it to stop feeding pellets after the first batch and the only way to get it going is to hit the manual reset button on back. Door is very snug so I'm at a loss.

    Maybe it is the TC but whatever it is, is doing it every time I start it from cold but runs fine after I hit the reset and it gets warm.
  11. heat seeker

    heat seeker Minister of Fire

    Joined:
    Feb 25, 2011
    Messages:
    2,124
    Loc:
    Northern CT
    The instructions for my Croix also suggest heating the snap disk with a lighter while monitoring the contacts with a meter. The switch should change state within a few seconds of applying the lighter's heat, probably with an audible "snap".
  12. kinsmanstoves

    kinsmanstoves Minister of Fire

    Joined:
    Aug 29, 2007
    Messages:
    3,372
    Loc:
    Kinsman, Oh 44428 Brookfield, Oh 44403
    The manual does tell you that you might have to hit the reset but every once in a while. I have found out that if the stove sits for a day or longer you do have to do this. Not a big issue. It does run great once it is warmed up, just that period over 24 hours or so.

    Eric
  13. pip3398

    pip3398 Member

    Joined:
    Jul 23, 2008
    Messages:
    66
    Loc:
    Central New York
    Dex is right about the thermocouple. If it was anything else it would still not work when you hit reset. It is not getting up to temp quick enough and is cycling off. It may just be that the slider (feed adjustment plate) in the hopper is not open far enough. If closed to far, this will limit the amount of pellets that fall for initial start up.

    This is common when switching to a different pellet that might be a little longer. They don't feed as fast. Basically your stove does not think that the fire lit (job of the thermocouple) and won't feed because of that. When you push reset it dumps for another minute which then gets the thermocouple up to temp and everything works right.

    Any adjustment you make on the slider takes about 10 - 15 minutes of feeding to show up on the other end.

    I would suspect that your cab-50 is too new for the thermocouple to be just worn out.

    You may want to hold off on having the service guy come (he may charge you if it's just an adjustment). Your manual describes how to set the slider. This should be done anytime you change fuels. Short and long pellets will feed differently in Quad and heatilator stoves because of the open auger design.

    Good luck
    DexterDay likes this.
  14. saladdin

    saladdin Feeling the Heat

    Joined:
    Dec 29, 2011
    Messages:
    341
    Loc:
    West Tennessee
    This little problem did arise after it set for 3 weeks without running. The weather turned warm here fast in Tennessee. The thing that worried me was I had ti reset it 6 times in a row for "cold" starts.
  15. saladdin

    saladdin Feeling the Heat

    Joined:
    Dec 29, 2011
    Messages:
    341
    Loc:
    West Tennessee
    Think you are dead on. My service guy doesn't charge and just stopped by. He "turned up the feed rate in the control box a click" and it fired up. He told me he has had to do this to a couple of his new installs already.

    One good thing that came from this is I learned a lot about how the stove works and it got a hell of a good cleaning.
  16. saladdin

    saladdin Feeling the Heat

    Joined:
    Dec 29, 2011
    Messages:
    341
    Loc:
    West Tennessee
    And I have a heat gun that would be perfect for this. Thank you.
  17. Don2222

    Don2222 Minister of Fire

    Joined:
    Feb 1, 2010
    Messages:
    7,157
    Loc:
    Salem NH
    Hello

    Nice Canadian Comfort Industries Pelpro video that shows how to use a jumper to test the Snap Disc!
  18. rparker

    rparker Feeling the Heat

    Joined:
    Jul 17, 2011
    Messages:
    245
    Loc:
    Vermont
    Had the same type of problem with my Quad. Turns out is was the snap disk (sort of..). After a lot of probing and checking I found that the wire on the spade connection was not tight. A quick twist and crimp and everything is good.
    Sometimes it is that simple.
  19. Don2222

    Don2222 Minister of Fire

    Joined:
    Feb 1, 2010
    Messages:
    7,157
    Loc:
    Salem NH
    X2 ! !
    I had a very similar problem with the Avalon Astoria and it was a loose connection! See pics of switch and testing.

    See my thread
    Fired up the Pellet Stove last night and Auger was Dead as a Door Nail! Yellow 4 Troubleshoot Light of no help!
    http://www.hearth.com/econtent/index.php/forums/viewthread/80407/
  20. kinsmanstoves

    kinsmanstoves Minister of Fire

    Joined:
    Aug 29, 2007
    Messages:
    3,372
    Loc:
    Kinsman, Oh 44428 Brookfield, Oh 44403
    I have had numerous different makes of stoves have a bad crimp that caused a lot of problems.

    Eric
  21. saladdin

    saladdin Feeling the Heat

    Joined:
    Dec 29, 2011
    Messages:
    341
    Loc:
    West Tennessee
    Thank you so much for taking the time to find that. Appreciate it.

Share This Page