1. Welcome Hearth.com Guests and Visitors - Please enjoy our forums!
    Hearth.com GOLD Sponsors who help bring the site content to you:
    Hearthstone Soapstone and Cast-Iron stoves( Wood, Gas or Pellet Stoves and Inserts)

Auto Oiler not working on Husky 350...??

Post in 'The Gear' started by Drifthopper, Oct 12, 2011.

Thread Status:
Not open for further replies.
  1. Drifthopper

    Drifthopper Member

    Joined:
    Apr 12, 2007
    Messages:
    92
    The auto oiler on my Husky 350 is not working, tank is full, no oil coming out.
    I noticed it last weekend, stopped using the saw, got around to looking at it last night.
    Rinsed the oil reservoir out with alcohol, took the bar and chain off, (newer, decent bar and chain on the saw) cleaned it all off real good, cleaned the bar and groove out, turned my oil adjuster on the bottom back and forth, (had it originally set at the high notch), put it back together, filled the oil tank, ran the saw for about 30 – 45 seconds… no oil on the chain, took it all apart, no oil coming out of hole.
    I’m using that Tractor Supply $6.00/gal black jug oil.

    What should I do / check next?


    .

    Helpful Sponsor Ads!





  2. smokinj

    smokinj Minister of Fire

    Joined:
    Aug 11, 2008
    Messages:
    15,979
    Loc:
    Anderson, Indiana
    Sounds like you did everything I would do. Next just to make sure empty tank and try to run straight alcohol (I like kerosene) through it.....If you get nothing you need a new oil pump. (Leave bar and chain off this time)

    Gunk makes a good product for this as well. engine flush.
  3. joecool85

    joecool85 Minister of Fire

    Joined:
    Jan 24, 2010
    Messages:
    863
    Loc:
    Central Maine
    I'd use kero as well. Sounds like the pump is shot though, probably a plastic gear driven one and the teeth sheard off.
Thread Status:
Not open for further replies.

Share This Page