Classic 1200 Troubleshooting

Post in 'The Pellet Mill - Pellet and Multifuel Stoves' started by norcal73, Sep 24, 2011.

Thread Status:
Not open for further replies.
  1. norcal73

    norcal73
    Expand Collapse
    New Member

    Joined:
    Sep 24, 2011
    Messages:
    1
    Likes Received:
    0
    Loc:
    California
    When I plug in the fuse, the units blower comes on and I get a blue flashing light on the control box. Hit reset, disconnected thermostat wires, didnt turn off. Dont know why it's coming on after simply plugging in fuse. Sounds like blower only, doesnt try to light on its own at this point, but blower doesnt appear to stop either. Worked fine last year...less than a year old. Any suggestions? Trying to ensure it works good for the upcoming season but doesnt appear to turn off even with thermostat all the way down.

    Thanks for your time.
    Steve
     

    Helpful Sponsor Ads!





  2. kilbury

    kilbury
    Expand Collapse
    Balls of fire

    Joined:
    Apr 26, 2007
    Messages:
    251
    Likes Received:
    4
    Loc:
    Southern Tier, New York
    Stove will turn on anytime you lose power. Combustion blower will run for 15-20 mins and shut off, blue light is indicator of what setting the control box is set to and will flash for the first minute after you put power to the stove.
     
    Collapse Signature Expand Signature
  3. DexterDay

    DexterDay
    Expand Collapse
    Guest

    Like stated above. Anytime the unit is plugged in (either power plug or fuse) the combustion blowdd will come on and run cor a pre determined amount of time. It will eventually shut off after about 10 min (give or take) Try plugging it back in and letting it go for awhile (with the thermostat turned down/not calling for heat)
     
Thread Status:
Not open for further replies.

Share This Page

Entire Site copyright © 1995-2016 - email to webinfo@hearth.com
Hearth.com and HearthNet are property and trademarks of Hearth.com LLC Advertising Information