1. Welcome Hearth.com Guests and Visitors - Please enjoy our forums!
    Hearth.com GOLD Sponsors who help bring the site content to you:
    Hearthstone Soapstone and Cast-Iron stoves( Wood, Gas or Pellet Stoves and Inserts)
    Caluwe - Passion for Fire and Water ( Pellet and Wood Hydronic and Space Heating)

Getting ready for winter 2012 - Castille not feeding pellets

Post in 'The Pellet Mill - Pellet and Multifuel Stoves' started by G00k, Oct 7, 2012.

  1. G00k

    G00k Member

    Joined:
    Jan 25, 2009
    Messages:
    31
    Loc:
    Northern Baltimore County, Maryland
    Hello dere, pellet poppers!

    I'm coming into my fourth year with my Castille insert, and I'm no longer sure my heart is in it. The past two years, when I power it on for the first time, the exhaust blower needed a push to get started - worked okay for the rest of the season. This year, in addtion to that, pellets aren't getting pushed into the fire pot.

    I had vacuumed out all the pellets as part of the final clean of the past season, and so I put a couple pounds into the hopper, spun the exhaust motor's wheel, and powered up the system. I waited for a minute, and then pressed reset and waited and did it again, knowing it takes a couple of turns to get the pellets through to the chute. Nothing.

    I Googled and read the owner's manual. The manual is pretty lame for pictures, and I can't seem to find any pictures on the net.

    Does anyone have some pictures that show the locations of all three snap disks?

    Also, does anyone have a service manual that tells how to get the insert into a serviceable position? I don't want to wreck it by disassembling it blindly.


    Thanks for your attention,

    G00k

    Helpful Sponsor Ads!





Share This Page