1. Welcome Hearth.com Guests and Visitors - Please enjoy our forums!
    Hearth.com GOLD Sponsors who help bring the site content to you:
    Hearthstone Soapstone and Cast-Iron stoves( Wood, Gas or Pellet Stoves and Inserts)
    Caluwe - Passion for Fire and Water ( Pellet and Wood Hydronic and Space Heating)

Problem with my Whitfield Profile 20 pellet...

Post in 'The Pellet Mill - Pellet and Multifuel Stoves' started by DKNJ, Dec 2, 2007.

Thread Status:
Not open for further replies.
  1. DKNJ

    DKNJ New Member

    Joined:
    Sep 14, 2007
    Messages:
    8
    When I start the stove, the blower goes on high, the pellets drop and the fire starts without a problem. Then when the fan switches into low speed, there is an intermittent vibrating noise coming from inisde the stove, sounds almost as if the fan was rubbing on something, the lights on the side flicker and the air flow slows considerably, the flame gets lazy and the room air flow slows as well. I clean the stove very regularly, from the insides to the exhaust pipes. any advice would be appreciated, this stove is the sole source of heat for my downstairs room...
    I am pretty sure I need it serviced, but didnt know if anyone had any ideas for a simple solution

    Helpful Sponsor Ads!





  2. Shane

    Shane Minister of Fire

    Joined:
    Nov 21, 2005
    Messages:
    1,830
    Loc:
    Casper Wyoming
    No real simple solution comes to mind on that one. The lights flickering indicate a possible control board problem, there could also be an issue with the power supply maybe? Sounds like something, as a tech, that I would need to see and run tests on to diagnose.
Thread Status:
Not open for further replies.

Share This Page