Whitfield Profile 30 control panel problem (maybe)

mudlakes Posted By mudlakes, Nov 17, 2012 at 3:31 PM

Thread Status:
Not open for further replies.
  1. mudlakes

    mudlakes
    New Member 2.
    NULL
    

    Nov 16, 2012
    2
    0
    I have a Whitfield Profile 30 pellet stove. My problem is it stops working and the green light flashes rapidly. When I push the green power button then the red and yellow, heat and fan lights blink on and off, and at the same time you can hear a popping sound like points opening or closing. If I shine a light up the feed shoot the stove starts running. Everything seems to run except the ignitor, since the stove got the signal that it was lit from the light. If I shut it off and then back on, I get the red and yellow lights blinking again. So I shine the light back up the feed shoot and it starts running again, but no ignition. Usually after 3 or 4 times when I shut it off and then back on it will start without the light and run the normal start-up sequence and the ignitor working. It will then work for a while. Sometimes a few cycles (it's on a thermostat) and sometimes for a day or two. Then for no apparent reason I get the rapid green light and have to go through the hole process again. I've been told that it sounds like the control board. I don't want to buy a new board at $360 to find out that's not the problem. Any ideas.
     
  2. smwilliamson

    smwilliamson
    Minister of Fire 2.
    NULL
    

    Dec 28, 2009
    4,484
    776
    Loc:
    Southcoast, MA
    Your stove uses a photo eye to sense a fire...so yer faking it out. Weird. Let me think it through...
     
  3. gonzo499

    gonzo499
    Member 2.
    NULL
    

    Dec 8, 2010
    3
    0
    Loc:
    slc, UT
    did anyone ever have any ideas for this? mine is doing the same sort of thing, though I haven't put a light in the photoeye to fake it out. about every other day or so it gives me a big negative and clicks off and then back on and back off over and over until I open the thermostat contact. its driving me crazy. occasionally it'll just go, other times it is this ridiculous game. anyone have any kind of experience with this or heard of it happening?
     
Thread Status:
Not open for further replies.

Share This Page