Craftsman 358.351580 Not Starting

lindylex

New Member
Jun 29, 2020
2
Earth
Currently I am trying to repair a Craftsman 358.351580 chainsaw. I rebuilt the engine. It has all new gaskets, the muffler, carburetor were taken apart and cleaned in the ultrasonic cleaner. The carburetor has a new gasket kit and passes the pressure test and has no leaks. The cylinder pressure has 100 PSI. I got new gasket material in a tube for the crankcase. It has spark albeit not a new spark plug but has spark. It has a new piston ring.

It can breath, gets fuel, has spark and pressure. Not sure why it will not start. I adjusted the low and high, nothing. I dripped some fuel into the the spark plug chamber and nothing. I noticed it flooded the carburetor after lots of pulling. I am not sure what to do at this moment.
 

dougand3

Minister of Fire
Oct 16, 2008
1,176
North Alabama
100 PSI is borderline. I'd like 130+. But measuring this tiny engine can vary. You installed a new ring - did piston and cyl walls look good w/o scoring? Other possibilities: 1. mis-timed - pull FW and check key. 2. It is really flooded from early on...try an empty tank, clear crankcase of fuel, then add a tsp of fuel and see if you get a pop.
 

salecker

Minister of Fire
Aug 22, 2010
1,066
Northern Canada
Did you do a pressure /vacuum test after you had it put back together?
If not start there before you waste anymore time guessing.
If it passes then you can start diagnosing the issue.
Pressure test the carb while you have your tester out.
 

lindylex

New Member
Jun 29, 2020
2
Earth
] SOLUTION SOLVED [ After several ohms and some repeated mythical chants. The dust settled and the neophyte noticed he never place the bearing covered in a rubber boot on the pull start side back in the groove on the bottom side of the engine.