Enviro M55C FS Issues

  • Active since 1995, Hearth.com is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.


Dec 24, 2018
Vermont, USA
Please may I ask for your assistance? Placed calls to techs but 2 month backlog.

First issues were pellet stove just plain turned off (minus turn off sequence) with full fire within resulting in chamber full of black smoke leaving oily residue and stinky house. I did find that the damper set screw had loosened and that damper had vibrated nearly shut.

Have thoroughly cleaned the unit using leaf blower to suck out ash (unplugging vacuum hoses), disassembled and cleaned everything including entire firebox, combustion blower, vacuum hoses.

Next issue.
Only will start in on start up sequence intermittently. I hear a click when plugging in the power. That is when it will attempt start up. Otherwise when plugging in and no click the unit will not respond to the on/off button. (What is that click noise coming from? Could that be the faulty device?)
Currently when the start up procedure can be triggered it does not call for the augur to feed pellets.

To date have attempted to no avail:
- bypass vacuum switch
- bypass high limit/hopper lid switches
- tested all fuses
- tested incoming voltage ~ 120
- tested auger motor - fine
- tested combustion blower - fine
- tested convection blower - fine

I am not sure how to test the motherboard voltages so have not done that. Wondering if I should just order up a new mother, daughter board in anticipation of those being the issue.

Any ideas would be much appreciated. Thank you.
@johneh thank you.
Do you reckon I should order up both the mother and daughter boards or only the mother?
thank you.
A couple of questions before you spend money on a board
First when you start the stove the agitator runs all the time Right?
After 10 min. does it shut off and pulse with the auger motor? or does it just keep running?
@johneh It keeps running with the agitator. At 10m it does not shutdown. No auger rotation at all for the entire duration.
Thank you.
After rereading your posts I think the board is done you
probably should get both mother and daughter board
just to be on the safe side. In Canada, both boards will cost about 385$ in US funds
Thank you very much. I will order those up and post back here with the results.
@johneh thank you for your guidance.
have new mother and daughter boards in the unit. so far, so good. thank you.
  • Like
Reactions: ARC
You are more than welcome Keep warm
  • Like
Reactions: ARC
@johneh might I run this by you?
During my original debug I had managed to break off the high limit sensor which I bypassed and ordered up a replacement.

Post-replacing the mother and daughter board the unit worked fine with the high limit sensor bypassed ~ 3 days. Since I work right next to the unit I was able to keep an eye on it.

The high limit sensor replacement arrived yesterday and I put it in.

The unit then would not start. No lights on the daughter board. Nothing. Re-bypassing the high limit sensor and the unit still will not start - still no lights on the daughter board - no response to the on/off button. Yes, switched to manual.

Any ideas what my next steps might be?

Thanks ahead of time.
Check the fuses and the power to the stove
Did you unplug the stove while working on it?
Last edited:
@johneh thank you.
Yes, I had the stove unplugged during all work done.

Just checked 5 fuses (1 x 4amp, 4 x 2amp) on the mother board using multiamp volt meter. all good unless there is another one I am missing.

Figuring that the old motherboard did not appreciate my Tripp Lite 3 Outlet Portable Surge Protector I upgraded to Tripp Lite ISOBAR4ULTRA Isobar 4 Outlet.

Every time I plug it in I hear the click-click which normally means it will fire right up except that the power button on the daughter board is not responsive and no initial fuel type light.
Just now I swapped back in the daughter board to see if that might be it. No luck.
I am down to the last of it
Pull the plug off the board and check the continuity of the 2 orange wires
They are the hi-limit switch and hopper switch wireing
Check and make sure the daughter board plug is set firmly (no bent pins etc.)

I checked continuity on both orange wires. good. but then noticed this. would a spike in the line cause this or something else?
Would this, alone, be the cause of the issues above?

  • Like
Reactions: DevinM88
A spike or short circuit
update on this.
I replaced the wiring harness and have been periodically checking to see if any shorting such as previously posted occurs. nothing.
toasty warm again. for the moment.

have the good fortune of being able to schedule the local pellet stove expert to come out next week to check my work.
  • Like
Reactions: DevinM88 and ARC