Issues with quadrafire Mr Vernon pellet stove.

  • Active since 1995, is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.


New Member
Apr 17, 2023
I have an older Mt Vernon pellet stove. It's been giving me fits and won't start up. I cleaned it all out the last time like I normall do when it starts giving me issues. Pull the inside panels all out and vacuum behind the panels and by the heat tubes and clean things all up. Did this and wouldn't start. It will flash a blue light once every 10 seconds or so on start up. It will start dropping pellets but then no ignition. Bought another igniter off of Amazon which I'm sure isn't the best place but it was over the weekend. Took the old one out and had to splice the wires as that's how the old one was. Old igniter had no resistance after testing the two leads. Tried it again and goes through the same sequence of not igniting but will flash the blue light once every ten seconds and start dropping pellets. Even pulled the vacuum tube off and verified it was clean and also cleaned out the port where it plugs in by feeder tube. I'm at a loss. This stove has always served us well but I figured it was time to call the experts. Even bypassed the thermostat and jumpered the two wires to eliminate that out of the equation.
Stupid question does the igniter get hot?
Has the vacuum switch been tested to verify it's working?
The old one wasn't. The new one isn't either. I did check the new one and it has resistance in it but the old one has no resistance. Can they be wired backwards???
I would be checking as to why there is no power going to the igniter
It should not matter which way it is wired

Has the vacuum switch been tested to verify it's working?
He said that pellets drop on start up that in my small mind means the vac. switch is working as should
I played with it more after work. Lit the pellet manually and the stove worked fine and ran for a couple hours until the stove was up to the set temp. Then shut off and same thing. Before this I did take out control board and open up and there was an internal fuse in there but I tested it and it was good. Is there a way to have the control board tested to verify its working properly???
Chuckluedtke, I’m having a similar issue with an older Mt Vernon AE. Comb fan turns on, pellets drop, but igniter doesn’t get hot. Have you found someone to test your control board? Thx
Have you unplugged the igniter and checked for voltage at the connections?
So the 15A fuse on the control panel was blown. Replaced it and seems to be working now. But I’m not sure why this control panel fuse blew and not one of the two in-line 7A fuses going to the igniter?