QF MT Vernon AE Dead, Not Powering Up

  • Active since 1995, Hearth.com is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.


New Member
Oct 30, 2020
Westford, MA
My MT Vernon AE stove was unplugged from wall while it was running/burning.
Essentially a human error induced power failure. The 5 year old stove has survived
other real power failures but not this one.

When we plugged the stove back in the stove was "dead". Thermostat blank.
Snap disc was not tripped by the way.

I checked the red/green wires to tstat which are supposed to be 3.3v.
It's 0v both at the thermostat and in the stove. So no power to tstat.
The power supply is providing 120vac and 15vdc to the controller properly that’s
measured at the power harness while unloaded, disconnected from control board.
Under load the dc is 3-4volts, with power harness connected.

I tried unplugging each sensor one at a time from the control board but nothing changed.
Trying to find a short.

What I have tried:
- cleaning
- re connection of wires to thermostat
- new control board ($$$)
- getting ready to order new power supply unit ($$) << NEXT
- new snap disc 3
- new burn pot thermo
None of these fixed the issue.
Should I try a new tstat?


I’d call for a Quadrafire service technician but the local dealers I tried
have a 2-3 month backlog. Also contacted Quadrafire but they would not
provide any techical assistence, referring me to local dealers.

Tony Vezza