Quadra-Fire Castile Power Troubleshooting

  • Active since 1995, Hearth.com is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.

Duckboy

New Member
Feb 12, 2021
3
Oregon
Hi, I am new to the forum what a great resource! I have a Quadra-Fire fireplace insert purchased new in 2003 and I haven't used it much. I burn about 5-7 bags of pellets a year at most. I started my stove up before Super Bowl and when I came downstairs I smelled burning and the stove was off. I tried to restart it and it was dead, no call light, no nothing. I investigated the issue and it looked like the igniter had shorted out somehow. Since then I followed some troubleshooting tips on here. I've verified my outlet is working, checked all connections and looked for any other damage, the power cord is good, I replaced the 7 amp fuse with a 7 new amp fuse (the grey terminal/wire in the junction box has power), jumpered the thermostat (I have no power at the terminals for the T-stat), I have replaced the ignitor, I have replaced snap disc #3, jumpered snap disc #3, confirmed power at the grey wire at snap disc #3, confirmed power at the 4th terminal from the right for the control box connection and popped open the control box and checked the fuse and didn't see any other evidence of damage. Whenever I removed the control box the stove was unplugged. Any other ideas for troubleshooting or feedback would be much appreciated! Thanks again and what a great site;ex
 

Ssyko

Minister of Fire
Nov 6, 2017
4,245
Lorraine NY
Do you have the old grey colored control box? Or the clear one?
I don’t have acces to my pc tonight but i will get the pics in the morning that shows the pico fuse on the control board itself
 

Duckboy

New Member
Feb 12, 2021
3
Oregon
Do you have the old grey colored control box? Or the clear one?
I don’t have acces to my pc tonight but i will get the pics in the morning that shows the pico fuse on the control board itself
Okay, thank you! Yes, I have the old grey colored control box.
 

Duckboy

New Member
Feb 12, 2021
3
Oregon
Hey Ssyko, thanks for the help. After I posted this I lost power for about a week from a severe snow and ice storm. Previously, I hadn’t inspected both sides of the circuit board when I opened up the control box. Sure enough, it had failed. I replaced the control box and I am back up and running now.
 

Ssyko

Minister of Fire
Nov 6, 2017
4,245
Lorraine NY