Quadrafire my Vernon AE (powerless wall control became power supply now control board and now won’t ignite)

  • Active since 1995, Hearth.com is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.


New Member
Dec 29, 2022
So I started with no power to my thermostat wich I stupidly assumed was bad cause my old one was years ago with similar issue. I was wrong and it was my power supply so back she went. I was short on loot and am a DIY so I got a deferent power supply that was suggested on another forum and it worked. I now had power to the wall control wich immediately read comb fan or drop tube code. I cleaned it and did all the things to no prevail so I called a tech who seemed to want to just throw parts at it and He did find a cooked harness wich I ordered and made no difference besides causing a pin to fall out wich I replaced. I then double checked all my connections and looped the sensors again and the stove would cycle through cleaning and startup. Frustrated and freezing my hurt off I finally decided to manually ignite the pellets wich worked but it cycles cleaning periodically and needs to be restarted alot. But now I know it’s not its working properly just not igniting. I mean it did occasionally throw error for drop tube or comb blower wich were running fine and would go away when reset or an adjusted connections. I now have hit glued all the connections and they are fine. So I’m conclusion the ignitor was not working wich was new and tested appropriately. Either way my lady decided to order a new board wich was a budget breaker though couldn’t be helped. Now we put it in and all the same issues are popping up bring me back to the bs. So I am running all but the ignition now and neither board is igniting and both have same issue. I called the tech who came out the first time and has been kinda helpful who suggested a bad board from manufacturer wich I highly doubted and here I am. The ignitor is good but is not calling for power from the board or what not. I’m super frustrated and have checked all my connections, fuses and harnesses to everything including power supply.

So this is where I am at and these are my questions…..
- What should each side of my ignitor power supply read when in startup?
-any ideas that you could think of for any of this or similar problems in your experience.
- could something have shorted out another control board and if so what sort of rope should I use to hang myself, lol.

-Additionally I may send back the control board if I fix this in time to do so during the 30 return period and thought of going factory power supply maybe it has a wonky output idk I’m grasping at straws here.
Last edited:
Where are you buying parts that that they will take them back after being installed on your stove? Most places have a no return policy on electronic parts if they have been opened.
Have you measured igniter resistance when it's unplugged? Usually about 40 ohms.

Are you getting 110V to igniter during start cycle? If not, then the control board fuse may be open, or relay contacts damaged.
I did check the ignitors getting power and it was the connection. Now the comb blower doesn’t want to spin. I took it out and it’s making grinding noise so I think it’s smoked idk.