Quadrafire Santa Fe Got me banging my head against the wall!

  • Active since 1995, Hearth.com is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.


New Member
Nov 9, 2023
Just sold my Englander Pellet stove that worked nicely for many years. Picked up this Quadrafire Santa Fe and was told by the previous owner that it didn't burn the pellets well. Thought it needed a good cleaning. Got it home and completely dismantled it and gave it a good cleaning. It was plugged up pretty bad. Installed it in my home and it sat till this past week. Turned up the thermostat, the red call light comes on, and all it would do is dump a charge of pellets in the burn pot, ignite the charge, burn the charge up, then shut down. Hit the reset and it would do it all over again. When I checked for voltage at he auger motor it would stop after the initial dump then no voltage and it shuts down. I noticed when I purchased it the vacuum switch was missing and a jumper wire was installed. I purchased a new vacuum switch and made sure the nipple was clear. I've checked all the wiring and connectors, including removing the control board terminal strip and gently bending the contacts outward to make better connection. Since then I have replaced the thermocouple, thermocouple ceramic cover, and the control board. Still doing the same thing. The red wire that feeds the vacuum switch, then the snap disc #2, then the auger drive motor is loosing power for some reason. Was convinced that replacing the control board would fix it. But it didn't. Both blower motors work as they should. Seems like there is a circuit in the controller that times out when you press the reset button, then it just shuts down. If you press the reset button while there is a fire burning, hold onto your hat because the fire rampages out of control filling every inch of the fire box and it starts roaring and vibrating like it wants to explode. Scary man! Don't know what else to do. Have run it on jumper wires to no avail. What am I missing. Stove is clean as a whistle, all new parts. One time the fire ran away the glass started to crack. Now I need to replace the glass. What a nightmare!
Is the thermocouple inserted far enough that it and ceramic cover are touching each other? Sounds like the control is not seeing a fire to continue.
  • Like
Reactions: ARC
Yes it is. I read a post that mentioned this so I did make sure it was inserted all the way in. Thanks!
Also, I ran a diagnostic by putting the mode selector switch in the "0" position and it operated both blowers, the igniter, and the feed motor for 10 seconds each. So that eliminates bad connections, wiring. Also ran it on #6 and #7(+10% feed rate option for low grade pellets)
What lights are coming on when you turn on the unit for heat? You should get a red call for heat light followed by a green light indicating that the thermocouple is seeing heat from a fire and if all is working properly, a red light after the thermocouple reaches 600 degrees.

Where did you purchase the new thermocouple from? Is it an OEM or aftermarket? I remember reading that people were having issues with aftermarket and replaced with OEM and everything worked again.
When I plug the stove in the blue light flashes six times, pauses, then flashes six times again, which is normal, indicating what position the mode selector switch is in. Mine uses position number 6. When I turn up the thermostat the red call light comes on, pellets dump, ignition occurs, then the power that goes to the auger motor goes away and the fire dies down, and the stove shuts down. No green light. The thermocouple that I bought for it was an aftermarket one. If there is supposed to be a green light that comes on it's not happening. I'll try purchasing a new OEM thermal couple. THANKS!
I have read on this forum that some after-market thermocouples are wired wrong
try swapping the wire positions. Then again I could be wrong but worth a shot
Thermocouples have positive and negative wires, therefore it is important to maintain the polarity during installation. For thermocouples with ANSI/ASTM Color-Codes, the negative wire is always red.
I reversed the wires on the aftermarket thermocouple and it made no difference. Still no green light. Waiting on OEM thermocouple to arrive.
UPDATE: I got the OEM thermocouple in today and installed it. That fixed the problem Thanks Johneh, You were right. Stay away from aftermarket. Stove starts and runs off the thermostat now. Lot of information on this site. Thanks to all that offered suggestions. Much appreciated.
  • Like
Reactions: DennsM and ARC
Just wanted to add this bit of information I acquired about my Quadrafire Santa Fe Pellet stove. I checked my vacuum at the nipple where the vacuum switch attaches with a digital manometer and i get -0.12 inches of water. Doesn't seem like much, but it operates the vacuum switch just fine. Before I checked vacuum with an automotive style vacuum gage and it didn't move the needle at all. The other related issue I was getting was that the glass was sooting up terribly in very little time. So badly you couldn't see the fire inside. The glass had a crack in it and I needed to replace it so I did some searching on the interweb and came across an article that mentioned some stoves leave out the door gasket along the bottom of the glass for an " Air Wash" to help keep the glass clean from ash buildup. This concept was concerning to me for two reasons. One- no gasket on the bottom of the door had me worried that sparks could possibly escape and start a fire. Two- The lower half of the stove already has massive air leaks from a vacuum standpoint. No sealing around the ash pan. So my concern was I was going to add to that deficit. When I replaced the glass I installed new gasket on three sides and left the bottom with no gasket. Just bare metal on the bottom. Well, to my surprise the glass does not soot up at all! I mean AT ALL! Its been running now for a week and I haven't had to clean the glass at all. Clean as the day I installed it. The fire is the best I've seen it. Perfect! Everything is operating perfectly now. All issues resolved. No sparks have come out either. So thanks to all that offered suggestions. Many Hands Make Light Work!
  • Like
Reactions: BigJohnfromCT