St Croix EXP Won’t fire up after cleaning

  • Active since 1995, is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.

Eddie Haskell

Oct 8, 2017
Kimberly, WI
Like the title states; I have an older St Croix Prescott EXP that won’t start after cleaning. It was purchased in 09 if that matters. I’ve tried everything that I can think of and am at a loss. I cleaned the stove, put it back together and now when I hit power, no go. It will turn on and the convection fan and the combustion fan both kick on, then after about 60-70 seconds it will shut down, the igniter does start to warm but it doesn’t run long enough to start a fire. It gives me an error code of lights 2 &3 blinking which is an indication of a High Limit error.
I have cleaned and disassembled and reassembled this and that, same result.
It would normally; start both fans for about 10 seconds then turn off convection fan until the fire was hot, then operate accordingly.
I know there are coincidences but this has to be related to cleaning…right?
What does the vacuum switch expect from the fire box, a tight seal or no vacuum at all? I currently have zero vacuum in the fire box.
Thanks for any help you can give me
OK. You get a vacuum when all doors,openings to stove are closed, and gaskets are in OK shape. The combustion fan draws air through and creates this vacuum. Now,I am pretty sure that-
code 2 means no vacuum pulling the switch shut. However, sometimes they can be damaged by a vacuum cleaner, and, more likely, the "nipple" where the hose hooks to, on the stove, gets crud in it. But you said you have no vacuum, how did you test this?
code 3 means proof of fire did not shut, to keep stove running. Well with no fire, that is what happens.
This model of stove both 1&2 lights blinking is supposedly a high limit error at least from what I’ve researched.
To test the vacuum I did it the old fashioned way and I removed the hose from the switch and blew into it and it was like blowing into a straw, i drew in and it was the same…the fire box on these aren’t very air tight.
Ya, I think there are 3 different control boards. So, you did not actually check that the stove itself was drawing a vacuum. Anyway, you could temporarily jumper vacuum switch and see if it lights. I do believe on all of them, it id does not see vacuum within 60 seconds, stove auto shuts down.
  • Like
Reactions: hockeypuck
I have tools around here to pull vacuum tests but these fireboxes aren’t air tight, I believe the combustion fan does most of the exhaust work. That’s what is confusing me, what vacuum is it looking for?
Either way, I bypassed the vacuum switch and it still shuts down.
You don't "pull a vacuum" on a stove to test it, of course they are not air tight. You hook in a magnehelic gauge and measure it, as the combustion blower is running. It is very slight, but stoves are calibrated around it.
As jumpering did not work, then I'd check all wiring inside stove.
This issue has been resolved. I ended up replacing the board/controller. The board has some upgraded features, we’ll see if I use them.
After thinking things through, as soon as it started dropping pellets and the igniter warmed, that indicates it passed the vacuum test so there isn’t much left as far as possible issues. The only thing it can be is the controller as it doesn’t move through to the next step which I believe in this case would have been to turn off the convection fan, it stops the whole process eventually and shuts down completely.
Thanks for the help MT Bob
  • Like
Reactions: Mt Bob