Whitfield wp2 - blower room fan stops spinning

Status
Not open for further replies.

Minihoser

Member
Nov 21, 2016
6
CA
Hi, noticed room blower fan on Whitfield wp2 advantage would vibrate and stop spinning. Removed lubed and reinstalled and issue continued. Noticed it spins fine on low. When I turn up half way it spins fine. Turn up to high it will spin up to high, then when auger turns, blower fan will vibrate and spin to stop and restart.

Replaced blower and new one has exact same issue. Runs fine up to 3, when turn to 5, it will speed up until auger turns, and then stop and restart. if I shut off auger to shut down, it seems to spin fine.

Thinking possible voltage power problem, seems when it draws power to auger room blower fan speed changes and forces it to stop and restart.

Controls are black dials.

Any thoughts.
 

johneh

Minister of Fire
Dec 19, 2009
2,865
Eastern Ontario
Think I would check wiring sounds like a ground problem to me
Welcome to the forum
 

Bioburner

Moderator
Aug 4, 2012
7,317
West central Mn
Or an issue with the control board :(
 

Lake Girl

Moderator
Nov 12, 2011
6,940
NW Ontario
Wiring diagram on page 34: http://www.pelletking.com/pellet-stove-manuals/whitfield-advantage-iit-pellet-stove-manual.pdf
Looks to be a connection on the power to auger and convection blower in the wiring. May just be a loose connection but would be concerned it is the board control not regulating power appropriately.

If the wiring checks out, there are board repair services for the Whitfields ...
http://pelletstovecontrollerrepair.com/
http://www.kijiji.ca/v-heater-humidifier-dehumidifier/peterborough/whitfield-advantage-ii-t-iii-plus-control-board-repair-service/265783976

Keep us posted on what you find... Remember to unplug when working in the cabinet!
 

Minihoser

Member
Nov 21, 2016
6
CA
Thanks for help, little more info...i can hear the blower fan surge or increase and decrease in speed as the auger turns...if fan goes to full power, auger will always disrute it and fan will rattle slow to stop and restart.

Checked wiring and had 2 fried wires leading to and from the pressure sensor....3 inches at end connected ti pressure sensor from power strip and end connector from auger to pressure sensor was fried....replaved both wires and cleaned and still have same issue...could this have jacked up control board or could faulty pressure sensor cause this...just adding some more info.

Model 67957...so no csr.
Thanks
Jason
 

Lake Girl

Moderator
Nov 12, 2011
6,940
NW Ontario
Pressure switch is designed to cut power to blower if it no longer senses appropriate pressure. Never heard of scorched wires to and from pressure switch... would suspect a short so replacement is appropriate. If blower problems persist, snap disc function should also be verified. They fail on a more regular basis. Then look to the board...
 

bob bare

Minister of Fire
Oct 31, 2013
2,960
park county montana
I think bio is right(from my experience)As the blower changes when the auger kicks in,is a control board/controller problem.Also we do not understand disrute and replaved.Really sounds like a failed part caused damage to the control board.
 

Lake Girl

Moderator
Nov 12, 2011
6,940
NW Ontario
Just guessing: disrute=disrupt; replaved=replaced;lol Does make things hard to read sometimes but those phones can be tough to type on;)
 
  • Like
Reactions: bob bare

bob bare

Minister of Fire
Oct 31, 2013
2,960
park county montana
Just guessing: disrute=disrupt; replaved=replaced;lol Does make things hard to read sometimes but those phones can be tough to type on;)
do not care,don't wanna know,if they are not smart enough to use literate speech.do not care,they need to grow up.
 
Status
Not open for further replies.