breckwell BigE fuse.

Post in 'The Pellet Mill - Pellet and Multifuel Stoves' started by MSmith66, Jan 17, 2013.

  1. MSmith66

    MSmith66
    Expand Collapse
    Feeling the Heat

    Joined:
    Feb 5, 2008
    Messages:
    404
    Likes Received:
    26
    Loc:
    Central NY
    Fuse blows when stove is plugged in. Combustion blower is good, control board is good. Checking convection blower and auger motor.

    Thanks in advance.
     

    Helpful Sponsor Ads!





  2. imacman

    imacman
    Expand Collapse
    Guest

    Ignitor?
     
  3. kinsmanstoves

    kinsmanstoves
    Expand Collapse
    Minister of Fire

    Joined:
    Aug 29, 2007
    Messages:
    3,471
    Likes Received:
    499
    Loc:
    Ravenna, Ohio 44266
    check your ground wire at the adapter that connects to the stove. If not that it should be the igniter, as Pete said.

    Eric
     
    Collapse Signature Expand Signature
  4. imacman

    imacman
    Expand Collapse
    Guest

    Quick test for the ignitor is to unplug one ignitor lead and see if the stove will attempt start-up w/o blowing fuse.
     
  5. MSmith66

    MSmith66
    Expand Collapse
    Feeling the Heat

    Joined:
    Feb 5, 2008
    Messages:
    404
    Likes Received:
    26
    Loc:
    Central NY
    Thank you both
     
    imacman and kinsmanstoves like this.
  6. imacman

    imacman
    Expand Collapse
    Guest

    Let us know if it works.
     
  7. MSmith66

    MSmith66
    Expand Collapse
    Feeling the Heat

    Joined:
    Feb 5, 2008
    Messages:
    404
    Likes Received:
    26
    Loc:
    Central NY
    Vacuum switch. Wire was fried which burned out the connection.
     
    kinsmanstoves likes this.

Share This Page