Harman Accentra insert distribution blower

bizpup Posted By bizpup, Jan 6, 2012 at 2:01 AM

  1. bizpup

    bizpup
    New Member 2.
    NULL
    

    Jan 5, 2012
    1
    0
    Loc:
    Cumberland RI
    I have had a Harman Accentra fireplace insert for the last 5 years. It has not given me any problems up until this year. I run the stove on Stove Temp mode. The distribution blower has been running inconsistently this year. The fan will run strong for a time and then stop for a short period and then start up again. Any ideas what the problem might be ? Thanks
     
  2. dingees

    dingees
    New Member 2.
    NULL
    

    Feb 7, 2010
    33
    0
    Loc:
    NB,Canada
    have u ever had the fan out or cleaned the dust and lint out of it
     
  3. ironpony

    ironpony
    Minister of Fire 2.
    NULL
    

    Jan 22, 2010
    2,069
    585
    Loc:
    mid-ohio via St.Croix USVI


    agreed probably tripping the overheat switchy thingy
    forget the technical name
     
  4. superelastic

    superelastic
    New Member 2.
    NULL
    

    Mar 9, 2013
    1
    0
    Thanks guys...I had the same problem in this solved it. I've had my Accentra for at least 4 years and never knew how much dust and hair could collect in that fan. I had enough to make a cat :)

    I have an insert, so I had to slide it out on my improvised rails (wood planks and bricks), then get under there with a toothbrush and vacuum to get all the hair. Man this stove is running like a blast furnace now. Too bad the weather is warming up :)
     

Share This Page