1. Welcome Hearth.com Guests and Visitors - Please enjoy our forums!
    Hearth.com GOLD Sponsors who help bring the site content to you:
    Hearthstone Soapstone and Cast-Iron stoves( Wood, Gas or Pellet Stoves and Inserts)

Jotul 550 rockland. Plugged in but no power.

Post in 'The Hearth Room - Wood Stoves and Fireplaces' started by bigdaddybry, Nov 1, 2012.

  1. bigdaddybry

    bigdaddybry Member

    Joined:
    Jul 3, 2008
    Messages:
    40
    Loc:
    N. Prov. RI
    It was just working a couple of weeks ago. Got a nice fire going tonite, went to turn the fan on(i always use manual setting) and nothing. It's plugged right to a wall outlet that is working as i had to unplug a lamp that was on before plugging the insert in. i took the front grill thing off that covers the switch, but i really have no idea what i'm looking for. Should i call an electrician tomorrow or call an actual stove tech?

    I have a box fan on medium sitting in front of the insert now just to keep some air moving around and hopefully keep the temp down.

    Helpful Sponsor Ads!





  2. PLAYS WITH FIRE

    PLAYS WITH FIRE Minister of Fire

    Joined:
    Jan 28, 2011
    Messages:
    639
    Loc:
    Pittsburgh, Pa.
    An electrician can figure it but a dealer/tech might be the way to go unless you or a relative is handy. Should be a very simple circuit to figure out.

    The electrician may charge you twice to come out because this is not his business..

    The dealer/tech you can get an idea on the phone what it will cost and he can easily get the parts..

    A handy relative can do it real cheap(beer pizza) in this case you both win!

    The circuit should be in the stove manual, at least mine is.

    PS try the other setting to turn on the fan.
  3. EJL923

    EJL923 Feeling the Heat

    Joined:
    Oct 29, 2009
    Messages:
    465
    Loc:
    Western Mass
    Make sure the snapstat switch (right next to the variable speed switch) is in manual mode. It may not be hot enough to turn it on. Also make sure all the spade terminals are plugged in, and that the main power cord is pushed far enough into the stove terminal.
  4. cp20855

    cp20855 New Member

    Joined:
    Nov 19, 2012
    Messages:
    17
    When installer first plugged Jotul into socket A, no joy with the (manual) blower at all. He turned off the blower, then I unplugged the thing and plugged it into socket B-- blower worked fine. I plugged a lamp into socket A, and the lamp worked fine. So we unplugged the lamp and replugged the Jotul into socket A and it worked.

    No clue about why any of this happened. Just thought I'd share - in case it has something to do with your plug problem.

Share This Page