Need answers or suggestions for breckwell Big-E

vandall Posted By vandall, Mar 2, 2008 at 4:47 PM

Thread Status:
Not open for further replies.
  1. vandall

    vandall
    New Member 2.
    NULL
    

    Mar 2, 2008
    15
    0
    Loc:
    Upper Michigan
    I have a two year old Big-E. There seems to be a great deal of heat lost since it was new. I cleaned the blowers. Replaced the convection blower with the "new blower" from Breckwell. For lack of technical terms the new blower seems to have less force. I have heard of other blowers that might fit. Does anybody have any comment on these aftermarket blowers? Any model numbers?
    What should be the air temp coming out with the stove set at 3? I am in need of any information that may be out there. Please Help!
     
  2. buildingmaint

    buildingmaint
    Feeling the Heat 2.
    NULL
    

    Jan 19, 2007
    459
    6
    Loc:
    Oil City PA
    Mine is on # 3 right now and it is putting out 135-142 temps. Have you cleaned out behind the little doors that are in the combustion chamber ? They are on the back wall on either side of the burn pot. What was wrong with the old convection blower ? You can read my post about my "BIG E experiment "to see how hot I got my house. PS now the thermometer reads well over 150 .
     
  3. vandall

    vandall
    New Member 2.
    NULL
    

    Mar 2, 2008
    15
    0
    Loc:
    Upper Michigan
    Yes I have cleaned everything. I will be doing that temp test today. Going to use my remote out door themometer. Will let you know how it goes.
     
  4. vandall

    vandall
    New Member 2.
    NULL
    

    Mar 2, 2008
    15
    0
    Loc:
    Upper Michigan
    Hey there! Ran the temp test got 149.6 on 3? Guess the heat loss thing was all in my mind. Also ran a temp test on the unit I have from the Danson Group got 120 running on 3 not bad for a cheaper unit and I actually like the blower better on the Danson unit. Hey thanks for the info.
     
Thread Status:
Not open for further replies.

Share This Page