USSC 5660 wont start...

nick7777 Posted By nick7777, Mar 14, 2013 at 9:31 PM

  1. nick7777

    nick7777
    New Member 2.
    NULL
    

    Mar 6, 2013
    3
    0
    the warning light for the high limit switch flashes a few seconds after starting and the fans kick on full blast. we have replaced both limit switches, the motherboard, and the igniter. all of these have been suggestions of US stoves and im at a loss. any suggestions would be appreciated, or perhaps pictures of the wiring how those who have running models is setup.
     
  2. heat seeker

    heat seeker
    Minister of Fire 2.
    NULL
    

    Feb 25, 2011
    2,594
    388
    Loc:
    Northern CT
    All I can suggest is to check every inch of the wiring, especially to the overtemp switch, to make sure it's not damaged, or shorted to ground. Recheck the connections to the control board, also.
     
  3. SmokeyTheBear

    SmokeyTheBear
    Minister of Fire 2.
    NULL
    

    Nov 10, 2008
    13,363
    1,662
    Loc:
    Standish, ME
    Is it possible that the 4 pin connection at the control board is misconnected according to the wiring diagram in the manual the connections from the high limit switch goes to the last connectors on the right and the left. If that connection is off a pin there will be an open and that indicates a high limit trip.

    If you have a multimeter you can check out the high limit switch and its wiring by using it to measure the resistance across the two outer connections and you want the blue wire to be on the the number 1 connection and the orange wire to be on number 4 according to the diagram on page 32 of the manual.

    Remember power off and the stove unplugged also do the measurement with the connector removed from the controller.
     

Share This Page