Accentra vs CAB50 Pellet Stove

  • Active since 1995, Hearth.com is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.
Oct 23, 2006
45
My 2006 Accentra free standing has developed a crack in the auger tube. Very expensive repair since the feeder housing has to be replaced. Stove would have to be removed from my house and trucked to the repair shop if the repairs are done.

I'm looking at other brands instead of repairing it. The Accentra has worked well over the years but early on it was plagued with the sticky pellet/smoke in the hopper problem. That was fixed with a mod. Still, I went through two control boards and a few igniters.

I'm looking at the CAB50 Pellet Stove.

Anyone have this stove? I would like to hear comments -- pro and con.

Thanks group. Paul
 

Dataman

Minister of Fire
Sep 10, 2018
963
Newport, Wa
I looked at it and read lots of reviews in 2018. Went with Harmon XXV Instead. Got Floor Model in April. $3500 with tax.
 

Tim_M

Burning Hunk
Mar 28, 2010
229
Halifax, NS
I have an ‘06 Accentra insert which developed a crack where the auger tube meets the burn pot a few years ago. I patched it with auto muffler patch and it is still holding. Comes in a tube and cost around $10.

I know of at least one other person who had the same issue with the same year Accentra. Makes me think there is a problem with the weld at the end of the auger tube.
 
Oct 23, 2006
45
I have an ‘06 Accentra insert which developed a crack where the auger tube meets the burn pot a few years ago. I patched it with auto muffler patch and it is still holding. Comes in a tube and cost around $10.

I know of at least one other person who had the same issue with the same year Accentra. Makes me think there is a problem with the weld at the end of the auger tube.
That muffler patch is interesting. Since you've had it on for a while I assume the high heat isn't an issue.