Blower motor not always activating on Enviro Maxx

  • Active since 1995, is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.


New Member
Nov 13, 2023
The blower motor on our Enviro Maxx pellet stove sometimes activates but not always when the thermostat calls for heat. We replaced the blower motor and still have the same issues. Has anyone else had this problem?
Welcome to the forum
A little more information would be helpful
Which blower motor
Combustion (air to maintain fire)
Circulation (warm air blown into the room)
  • Like
Reactions: ARC
Do you have a manual?
The biggest thing I can think of is the
120ºF (49ºC) Ceramic Fan Temp Sensor
needs to be cleaned or replaced
Or maybe adj. the heat output settings
The stove has to reach 120::F for the fan to come on
If the 120ºF (49ºC) Ceramic Fan Temp Sensor
is covered in ash it will be hard for the sensor
to reach that temp Remove it and clean. If the fan
will still not run try jumping the wires if it starts
right away replace the sensor if it does not start possible board
Thanks for the info.

I tried jumping the motor before I took the sensor out and the fan worked just fine. I took the sensor out and it had indeed become caked up with ash. I cleaned the sensor and when I put it back in it still wouldn't work, so I jumped the fan and this time it wouldn't start. The motor is good, I tested it on it's own and it works fine. The furnace started firing again, even though the thermostat was not calling for heat. This leads me to believe it could be the circuit board. Any comments would be appreciated.
With the limited information, it is hard to diagnose.
You say the fan ran when you jumped the switch now
when you jump the switch it does not run. Have you fed
just the fan motor with 120 volts? Does it run? Is there
voltage being fed to the sensor? If you shorted the sensor
wire you may have let the magic smoke out of the board.
Is the fuse OK With no heat call nothing will work
Thank you again for the info. The fan does indeed run directly on 120. The fuse is good, the thermostat is good and the stove works properly on the manual setting with the exception of the blower starting. I'm starting to believe there is some kind of MAGIC SMOKE and it has been possessed. I need to find a service person who is willing to come out and fix it, but so far no luck in finding one who will service Enviro Maxx.