Englander 25-PDVC

Mikeporter Posted By Mikeporter, Mar 19, 2019 at 8:33 PM

  1. Mikeporter

    Mikeporter
    Member 2.
    NULL
    

    Jan 28, 2016
    22
    1
    Loc:
    Belwood Ontario canada
    well I moved my stove out to the garage. It lasted for 25 minutes and then burned out. The only time it runs the top auger now is when the ON push button is pressed. I homes out the door switch and the pressure switch when it’s running and they are working fine. It seems to have stopped cycling. Strange thing is when I ran the board functionality test when the blower is running the top auger isn’t. When the blower is off the auger starts running. Any ideas?
     
  2. Ssyko

    Ssyko
    Minister of Fire 2.
    NULL
    

    Nov 6, 2017
    2,209
    529
    Loc:
    Lorraine NY
    any wires ever get shorted to chassis? lighting/voltage spike? sound like some components on the board got the magic smoke released
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Pellet rick

    Pellet rick
    Feeling the Heat 2.
    NULL
    

    Nov 25, 2015
    347
    50
    Loc:
    Pottstown PA.
    Hopper switch?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Mikeporter

    Mikeporter
    Member 2.
    NULL
    

    Jan 28, 2016
    22
    1
    Loc:
    Belwood Ontario canada
    Well I pulled the board out last night and took it to the shop clean it and checked all the components with the huntron. Everything checked out. I replaced the 3 capacitors and it fixed the problem in diagnostics. I threw it back in and tried it. The room air blower comes on immediately. I think it needs a new temperature switch. I’ll get one and let you guys know how it went.
    Thanks for the replies.
     

Share This Page