Englander 25pdvc questions

  • Active since 1995, Hearth.com is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.


New Member
Feb 22, 2023
I just picked up a used 2012 model of the englander 25pdvc.
Got the unit set up on Monday and it ran fine for about 48 hours and 3 bags of pellets. Till today when it started having some actual issues.
1st. It seams the top feed auger doesn’t want to push anything into the feed hopper area sometimes. The stove will run for 5-10 minutes then there’s just no pellets being pushed into the burn pile.
I have manually feed pellets into the burn area from the door to give it more time to catch up. Not sure if this is good or bad: also don’t know how bad it is to open and close the hopper lid when I’m having this issue.
Right now the stove has been running for about 20 min from cold and it’s still going. The auger was very hot earlier today so I’m waiting till then and seeing what happens.

This happened no matter what heat setting I was on:

Also my unit won’t bring up any sub menus for the low fuel feed but took but it will for the air buttion.

Also the door seams to rattle when on heat setting 5 or higher. I say it’s the door as I can open it a smidge and the rattle/vibration goes away.
I’m guessing this is a gasket issue but not sure if it’s related to my first issue.

I am using Matra pine pellets.

This is my first pellets stove and trying to get the kinks worked out.

My main issue is it not staying lit.

Thanks Garrett
Also the door seams to rattle when on heat setting 5 or higher
Door should not rattle any any heat settings. If you have a barbecue cleaning brush lightly run it over the rope casket to fluff it up. If no brush any comb will work just takes longer. Door should fit tightly. Take a dollar bill close it in the door and try to pull it out should not pull out easy, do this all the way around door. You could be intermittently be losing vacuum and that would stop the auger. Can you hear the auger motor trying to run when it has stopped pushing pellets, you should hear a hum or groan if it is trying to turn.
So a I’ve tried a few morn things.

The unit seams to feed good/consistent on heat setting 3 or lower.

Anything 4 or over it feed for 5-15 minutes and then the top auger stops.

The door chatter is air chatter. Idk how else to deccribe it.
If I partially cover the air intake in the rear it instantly goes away.
When the rattling is going on the flame is also pulsing.
It only does this on setting 4+ as well.

Not sure if the two issues are connected but this is what I’ve done so far.

I have bipassed the hopper saftey switch tonight and is hasn’t made a difference.

I’m going to pop the rear panel off tomorrow and check to make sure the motors are strong and everything is tight.
I have bipassed the hopper saftey switch tonight and is hasn’t made a difference.
Try bipassing the vacuum switch attached to back of the fire box, the upper auger runs through that vacuum switch. You could also bipass the other vacuum switch attached to the exhaust blower housing. I think the exhaust blower surging is trying to establish the proper vacuum.
The same way you bipass a hopper switch, low limit or high limit switch. Unplug stove, remove 2 wires from vacuum switch attach two wires together using a small jumper lead or paper clip, tape connection, plug stove back in. With stove plugged in do not touch bare wires to body of stove will short the board. That is the purpose of taping the connections even if you only have scotch tape or masking tape to use. Jumping/bipassing the switches is only for testing purposes it is not a fix. If auger then works then you either have a vacuum problem or the vacuum switch is bad. Vacuum problems are usually:
1. dirty stove or venting
2. plugged or cracked vacuum switch hose
3. bad door gasket (hopper or ash pan gaskets if stove has them)
4. bad vacuum switch
5. bad exhaust blower

Read comments on youtube video

male spaded jumper wire.jpg
While your in there check to make sure the Heat Sensor screw is tight, If loose the stove not register proper temperature and turn off auger. Should be white cloth covered wire, but some replacement sensors had black cloth cover.

Englander 25pdvc questions
Englander 25pdvc questions
So I definitely have a bad hopper gasket
And bipassed the vac system

I got the stove running and made the hopper gasket the best I can and it barely made the noise and flame buffer I was describing before so I think that’s part of that issue:
But the stove did shut down again.

This is the first time I’ve had the rear of the stove off and the top auger motor is a lot harder to move up and down then the bottom one:

I’m going to let it cool off and grease and oil that motor up.
I’m guessing it’s getting hung up with to much pressure of the higher speeds.
Not sure if that’s a thing but gonna try it.

Who ever put these motors in 0ut the grease fittings up so you came get your gun on them so I’m guessing it’s never had grease.
Correct the switch was bipassed and it shut down.

Took the motors off today as the grease fittings where vertical and not possible to get grease into them.

Got those turned around, greased and also switched the motors from top to bottom.

Also not sure if this matters but it looks like there is 2 vacuum switches in the unit
Only saw one last night as the other one on the exhaust side wasn’t hooked up with any piping just wires:

So I bipassed that one as well.

I haven’t had a chance to run it yet I’ll be home again tonight to do a long hot burn and see what happens
  • Like
Reactions: ARC
If I remember right, the one exhaust side controls power to the upper auger motor, the one on the back of the firebox "talks" to the control board. There is a jumper on the board that you could bypass (for testing purposes only!) without having to mess with the switch itself.

It sounds like you're on the right track. Good luck!