Enviro M55-cast iron insert

  • Active since 1995, Hearth.com is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.


New Member
Nov 20, 2023
Our Enviro m55-cast iron pellet stove insert is stuck on #3 flashing. When we pulled the stove out, one of the wires for the vacuum switch was shredded by the blower motor. We repaired the wire but were still stuck on #3 flashing. After fixing the gray wire, when starting up the stove, the auger doesn't seem to run but the agitator seems to run for 5 minutes with the combustion blower on.

So far we have checked the ignitor resistance (was 35 ohms), the exhaust temp sensor is measuring open (-is this correct?) , we've cleaned and reset the burn pot, tried putting a handful of pellets into the burn pot. Also bench tested the auger and it spins. All the fuses are good. No other wires appear to be damaged.

Is there anything else we should check? Thanks in advance.
Have you tried jumping the vac switch?
will the auger work with the switch jumped?
Does the stove start, fire up and run normally?
Did you blow out the vac hose (toward the stove )?
Welcome to the forum
Yes the exhaust temp sensor will be open untill the exhaust reaches around 120 Deg
if the stove does not reach that set temp after 15 minutes the stove will shut down
(AKA proof of fire switch)
Jumped the vac switch, doesn't look like the auger is working, only the agitator. The stove doesn't fire up and run. The combustion blower turns on, and the the agitator will turn on and run for five minutes. It then appears to time out and blinks #3.

The convection blower isn't turning on unless we disconnect the vacuum line from the vacuum switch.
Have you checked the over heat switch? Has a red button on top
push it down and see if it clicks
have you checked the fuse for the auger motor?
Last edited:
Yeah. Even bypassed the magnet while we were in there. We've checked everything at this point since posting. Tested all the fuses and bipassed as much as we could. The augur motor isn’t getting power but when we bench tested the augur/motor it was fine. So were assuming its the control board?
Looks like the board has lost its magic smoke
This is what the manual says for your problem….

3. The exhaust motor will not function normally.
• Check the line fuse to see if it has blown.
• Open the access panels; check all connections against the wiring diagram.
• Check the Exhaust Blower voltage across the blower motor wires (>=115V on #5 setting and >= 75V
on #1 setting). – Replace the Circuit Board if the Voltage reading is less than 75 V. with a line voltage
of >115 V AC.
• Clean all exhaust passages and venting.
• Check and, if necessary, replace capacitor.

4. Light # 3 on Heat output bar flashing (The Exhaust Temp. Switch contacts have opened.)
• Stove ran out of fuel - check fuel level in the hopper.
• See sections #2 - Stove will not operate when hot, #3 - The Exhaust motor will not function normally,
and #5 - Unit is on but auger does not turn at all for more suggestions.
• Severe negative pressure in area where unit is installed - Check the operation by opening a window,
does this solve the problem? If it does, install fresh air intake to unit or room. Venting system may
require vertical section to move termination into a low pressure zone. • To reset Circuit Board after a trouble code - push the ON/OFF button

• Combustion Blower failure. - The Combustion Blower is not turning fast enough to generate the
proper vacuum in the fire box. Visual Check – is the blower motor turning. See section #3 - The
Exhaust Blower will not function normally.
  • Like
Reactions: jjam