ESP Probe Harman Invincible Insert

NHMarkT Posted By NHMarkT, Oct 9, 2018 at 8:04 AM

  1. NHMarkT

    NHMarkT
    New Member 2.
    NULL
    

    Oct 9, 2018
    7
    0
    Loc:
    Brentwood, NH
    Hi from NH. I bought a Harman Invincible Insert used 4 years ago and it has worked great for me. I cleaned it yesterday for the coming season and plugged it in.
    I have 3 blinking lights .The blowers will not shut off. The feed motor runs just enough to keep it burning but no more.
    I have read on here that my problem is most likely the ESP probe. I see the external one that plugs into the front but it sounds like there is an internal one also? I have read that they can get soot covered and may just need cleaning? I have followed the external probe wires back to the board and they look ok.
    If anyone can steer me in the right direction I sure would appreciate it.
    thanks
    Mark
     
  2. DAKSY

    DAKSY
    Patriot Guard Rider Moderator 2.
    NULL
    
    Staff Member

    Dec 2, 2008
    7,608
    1,410
    Loc:
    Averill Park, NY, on Burden Lake II...
    Try a Manual Reset. Unplug the power cord for a few seconds. Plug it back in & see if the blink stops...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. NHMarkT

    NHMarkT
    New Member 2.
    NULL
    

    Oct 9, 2018
    7
    0
    Loc:
    Brentwood, NH
    I tried the manual reset but with no luck. Also, I am plugged directly into the outlet. I read on here that the surge protector could be the problem. That wasn't it. I can replace the probe on the outside - is there an internal one that controls the stove temp? If so, how can I find it. Thanks!
     
  4. rona

    rona
    Minister of Fire 2.
    NULL
    

    Apr 2, 2008
    958
    239
    Loc:
    southwestern Minn
    Remove the ESP and clean it it sounds like you have never removed it to clean it. This should be done once a year as preventative maintenance there is a small metal screw that you need to remove using a small socket and extension. Sometimes you might need a small screw driver to lift that screw as the heat will have deteriated the threads on that screw. Use a new screw when you put it back together. Basically a simple job
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    Overfireinthehole likes this.
  5. DAKSY

    DAKSY
    Patriot Guard Rider Moderator 2.
    NULL
    
    Staff Member

    Dec 2, 2008
    7,608
    1,410
    Loc:
    Averill Park, NY, on Burden Lake II...
    In all probability, you will need to pull your insert out of the fireplace to access the ESP. In Harman units, the ESP is in the exhaust port just before the first section of pellet vent or pellet liner...It will be attached to the port from the outside, & held in place with a 1/4" zipscrew.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    rona likes this.
  6. NHMarkT

    NHMarkT
    New Member 2.
    NULL
    

    Oct 9, 2018
    7
    0
    Loc:
    Brentwood, NH
    Yep- I’ve never cleaned it. I’ll look for it tonight. Thanks!
     
  7. NHMarkT

    NHMarkT
    New Member 2.
    NULL
    

    Oct 9, 2018
    7
    0
    Loc:
    Brentwood, NH
    Great- thank you! I’ll take a look tonight.
     
  8. NHMarkT

    NHMarkT
    New Member 2.
    NULL
    

    Oct 9, 2018
    7
    0
    Loc:
    Brentwood, NH
    I removed probe, cleaned and reinstalled. The blowers come on immediately when I plugged in, even in the off position. Still getting 3 blinks.
    I checked the wire( it’s white) and it looks good back to the board. Do I replace it? Anything else to try?
    Many thanks
     
  9. DAKSY

    DAKSY
    Patriot Guard Rider Moderator 2.
    NULL
    
    Staff Member

    Dec 2, 2008
    7,608
    1,410
    Loc:
    Averill Park, NY, on Burden Lake II...
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. Overfireinthehole

    Overfireinthehole
    Member 2.
    NULL
    

    May 5, 2017
    240
    56
    Loc:
    Miller MO
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. NHMarkT

    NHMarkT
    New Member 2.
    NULL
    

    Oct 9, 2018
    7
    0
    Loc:
    Brentwood, NH
    so I ordered a new ESP and room sensor. Installed both. Still getting three blinks and the fans come on immediately upon plug in ( even in off position) and will not turn off. tried another reset to no avail.
    any other ideas before I call a service company?

    thanks!
     

Share This Page