Heat n glo sl550trs-c

  • Active since 1995, Hearth.com is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.


New Member
Oct 23, 2021
I have a heat and glow gas insert fireplace and have the following issue. There is a thermostat on the wall as well as an on off switch on the gas valve. Occasionally, when the thermostat is in “heat on” mode the burners do not come on. When this happens I can flip the on / off switch on the gas valve to on for a couple seconds and the burner stays lit when switching it back to off until the thermostat reaches desired temp and it shuts off normally.

thermopile is reading over 600mv when nothing is on
when thermostat is in “heat on” mode and burner is on, it reads over 300mv
when on/off switch is on, it reads just under 200mv with thermostat in either “heat on” or off mode.

when the thermostat goes into “heat on” mode from off I can hear the same click noise regardless if the burners come on or not as if the circuit contact is made to open the valve.

Picture of gas valve is attached, many thanks on any ideas of possible issue!

Heat n glo sl550trs-c
Pull the thermostat & jump the wires a couple of times.
If the unit comes on EVERY time, then the T-stat is questionable.

Two years ago I replaced the thermostat per the above advice and it has worked until trying to restart it today.

Today, when I pull the wires out of the thermostat and cross them, the fireplace does not start. When I leave them crossed and flip the switch on the valve on and off the fireplace stays on until I uncross the thermostat wires.

Any ideas what to check ?
Hmm. New one on me…Wires tight at the gas valve?
Thanks for the reply both 2 years ago and today. Thought I replied then to say thanks but it must’ve not submitted.

after posting yesterday I noticed in the utility closet behind the thermostat that the wire was pulled out of its clip on the way to the crawlspace. I put it back and it’s working better. Also , cut off the ends of the wires and exposed new wire to insert into the thermostat. I’ve cycled it on an off a bunch of times, but one time fireplace didn’t ignite for a minute after “heat on” And another time it didn’t come on at all.

maybe some rodent damage to wire in crawlspace ? i can’t see where the thermostat line connects to the valve. taking apart the valve to look kind of scares me. Have to crawl from 2 units over in small space to get underneath my condo, ugh ! If I’m going to call someone in , may as well replace the valve and pilot light assembly then hopefully won’t have to deal with it for a while ?
Hmm. New one on me…Wires tight at the gas valve?
More data after valve stopped working via thermostat again

thermocouple voltage readings:
thermostat off, manual on switch off- 600mv
Turn thermostat “heat on”, leave manual switch off, fireplace has no flame -375
Leave thermostat “heat on” , turn manual switch on and fireplace flame ignites - 175
Turn manual switch off with fireplace on, leave thermostat “heat on”, fireplace flame remains - 375

Given that the voltage drops with thermostat “heat on” , does that mean thermostat circuit is complete and not the issue?

Since valve opens when manual switch is on, does voltage drop means extra voltage going to the valve so it opens ?

if that’s true is the correct read that valve is the issue and needs replaced ?
175mV maybe too low to actuate the valve. I think I’d replace the thermopile & see if the unit functions normally.
175mV maybe too low to actuate the valve. I think I’d replace the thermopile & see if the unit functions normally.
Damn ! New thermopile worked once via thermostat then it stopped again. Voltage readings: 700mv, 500, 200, 500 same order of the previous report.
175mV maybe too low to actuate the valve. I think I’d replace the thermopile & see if the unit functions normally.
I got another tip from local store to try taking the manual switch out of the wiring path and it worked!

my wiring path was: thermostat to switch to valve.

So looks like the answer to “crossing wires at thermostat doesn’t work and manual switch does” means something wrong with manual switch in off position. cleaning manual switch terminals and reconnecting didn’t work.

thanks again for replying
You can probably get a replacement rocker switch from Amazon, but your local Heat & Glo dealer might give you one…