Help- First time using stove compete chit down including digital display

Vince37

New Member
Oct 6, 2019
1
NY
So we were excited to use our new Harman Accenture 52i-TC. I used it for a bout 2 hours last night in temp mode and it worked fine but it shut down once it reached the temp of course.

This morning I put it on constant burn with high fan settings. Worked beautifully and was cranking until about 2 hours later the complete stove shut down including the digital display. Power is fine no short as I have my tv plugged to the same outlet and it’s working. Double checked the breaker and looks good so power doesn’t seem to be the issue.

so right now my stove looks like it is completely off and not even plugged in. Did I break this thing already?
 
Last edited:

jackman

Feeling the Heat
Jan 15, 2013
482
Oregon
If it's new and under warranty I'd call the dealer. If not, I'd check the fuse on the control board.
 
  • Like
Reactions: Vince37

BigJohnfromCT

Feeling the Heat
Dec 29, 2012
253
Danbury, CT
Ditto, what Jackman said. If under warranty the only thing you should do is make the call. Anything else might void your warranty. One thing to check, does the power cord also plug into the stove? My MVAE plug is removable from the stove much like a computer monitor. Are there any indicators inside the unit that might give you a clue. Good luck.
 
  • Like
Reactions: Vince37

Overfireinthehole

Feeling the Heat
May 5, 2017
467
Miller MO
Double check the cord is making a good connection on the left hand side. If it’s not just a loose connection, have your dealer out. I’ve had a couple of those touch screens that were bad from the factory. Wouldn’t hurt to plug it into a new outlet.