Husqvarna yth18542 mower won’t move.

Dvanlinton2

New Member
Jul 30, 2020
7
Red springs nc
I need any help if possible. I did everything with this riding mower from not moving in the past. Push the pin in the back so it could move. Even had the timing belt slip off a few times.. what happen to me today was my blade gaurd was a little low and I hit a stump that was in the ground and made a complete dead stop. And it wount move forward or backwards.. I kinda had this problem before the timing belt slipped so I had to remove the back battery and press on the gas to loosen up the pull to put my belt back on. But in this situation I notice the belt was fine but when I press on the gas the pully doesn’t move at all. So this is the problem I spotted my question is how do I fix it or part name so I can search for it. Any help would be much appreciated...
 

johneh

Minister of Fire
Dec 19, 2009
2,944
Eastern Ontario
Are the pulleys moving at the motor?
in other words is the belt spinning?
 

Dvanlinton2

New Member
Jul 30, 2020
7
Red springs nc
Are the pulleys moving at the motor?
in other words is the belt spinning?
That’s a good question I have to get back to you tomorrow am. I’m away right now. I know that the seat is pressure sensitive when I get up it cuts off. So I might have to try to record and find out if they are spinning ty..
 

Dvanlinton2

New Member
Jul 30, 2020
7
Red springs nc
Are the pulleys moving at the motor?
in other words is the belt spinning?
Yes the belt is moving when I have the blades moving, only thing I see not working is driving forward. But like you said if that pully don’t move while I’m pressing the gas like it use too them something is wrong right.
 

johneh

Minister of Fire
Dec 19, 2009
2,944
Eastern Ontario
So let me get this right the drive belt is not turning the trans pully
but the blades work OK
If that is the case turn the machine off and try to turn the drive pulley at the engine
does the pulley and belt move does the trans pully move?
If they move freely then I suspect the engine pulley key is broken
The key is the mechanical connection between the engine pulley and the crankshaft
 

Dvanlinton2

New Member
Jul 30, 2020
7
Red springs nc
So let me get this right the drive belt is not turning the trans pully
but the blades work OK
If that is the case turn the machine off and try to turn the drive pulley at the engine
does the pulley and belt move does the trans pully move?
If they move freely then I suspect the engine pulley key is broken
The key is the mechanical connection between the engine pulley and the crankshaft
The belt only spins around when the blades are on. But not when the blades are off I’m not even sure if that’s a issue or not I haven’t paid attention to that before but Mashing the gas pedal does not move anything at all. And the belt touch not move freely when the engine is off..
 

johneh

Minister of Fire
Dec 19, 2009
2,944
Eastern Ontario
There should be two belts one for blades one for transmission
check the trans pulleys and belt
 

johneh

Minister of Fire
Dec 19, 2009
2,944
Eastern Ontario
If the belt does not turn the pully will not turn (By the video is not Belt or pully)
The belt is off a pulley or idler pulley or off the engine pulley
The belt that makes it go is not the same belt that drives the blades
pull the more deck off and check the belt that drives the trans
 

Dvanlinton2

New Member
Jul 30, 2020
7
Red springs nc
If the belt does not turn the pully will not turn (By the video is not Belt or pully)
The belt is off a pulley or idler pulley or off the engine pulley
The belt that makes it go is not the same belt that drives the blades
pull the more deck off and check the belt that drives the trans
Ok I took the deck off to have a good look. At first the belt did not turn but then it turned good with the pully then it got stuck again somehow. but it does all turn when I moved it
 

johneh

Minister of Fire
Dec 19, 2009
2,944
Eastern Ontario
The belt that goes to the trans should be TIGHT only loose when the Park Break is on
When you push the go pedal it just engages the trans internally has nothing to do with the belt unless
the belt is not powering the trans pump. Again I say the belt has jumped off a pully somewhere
 
  • Like
Reactions: Dvanlinton2

Dvanlinton2

New Member
Jul 30, 2020
7
Red springs nc
The belt that goes to the trans should be TIGHT only loose when the Park Break is on
When you push the go pedal it just engages the trans internally has nothing to do with the belt unless
the belt is not powering the trans pump. Again I say the belt has jumped off a pully somewhere
The belt is in place where it should be I fully investigate all the pullys. Cause usually when the belt slips. It slips from the back. That’s why I knew about the gas when I press it. It makes it easier to put the belt back on from the back. You said something about the engine key being broke. I search for that and only thing that pop up is the ignition key
 

begreen

Mooderator
Staff member
Nov 18, 2005
83,566
South Puget Sound, WA
The belt that goes to the trans should be TIGHT only loose when the Park Break is on
When you push the go pedal it just engages the trans internally has nothing to do with the belt unless
the belt is not powering the trans pump. Again I say the belt has jumped off a pully somewhere
Yes, it may have jumped an idler pulley in between the motor and the transmission. Another possibility is that the belt was stretched and no longer is doing a good job of engaging the transmission. But in that case the mower should move a bit in forward or at least reverse, even if slowly. johneh provided some good videos up above. Watch them. They will show you the idler pulleys and belt routing. Also, check that tip on grass under the brake pedal mechanism. It's a common issue. I use an air nozzle to blow out grass after mowing to prevent this.
 
Last edited:

begreen

Mooderator
Staff member
Nov 18, 2005
83,566
South Puget Sound, WA
Moving this over to the Gear forum. It's not really DIY.

If it's any consolation, I went through something similar with a Craftsman Pro (Cub Cadet XT2 equiv.) recently. The mower only had 28 hrs on it when the drive belt jumped the idler pulley. I got it back in place but then it would go slower in forward and could not climb hills very well at all. Eventually, in the next hour of use it wouldn't go up our driveway at all and the machine shuddered when going up slopes. The belt was sloppy like yours. I replaced the drive belt with a good quality Kevlar belt (not the MTD OEM crap) and it's been fine since.
 
Last edited:

PaulOinMA

Minister of Fire
Oct 20, 2018
696
MA
I have a 1995 Simplicity Landlord garden tractor. When I had a drive issue ... would move, but had real trouble with the slope from my backyard to the front ... it was the spring in the drive belt pulley set up. It was worn out. Not enough tension on the drive belt.