Mt Vernon AE insert-"Bad TC Drop Tube" error message..followed trblshooting guide and stove still will not proceed past the error code...ugh!!

  • Active since 1995, is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.


New Member
Jan 14, 2023
Wantage NJ
Message:**hello all...have been following this forum for a couple weeks now in hopes of an answer to my quadra fire insert woes.... i am at a complete loss on where to go from mt. vernon quadra fire ae insert throws a bad TC drop tube....ive read some previous threads and followed as best i could on the troubleshooting sequence and still have the same code appearing...please let me bring you up to speed lol...the stove will not even get to a point where it starts its normal startup immediately goes to bad tc drop tube...i have already replaced both the tc drop tube and firepot tc... along with a new snap disc#3(which i found the terminals to be somewhat charred...fixed them and tested for positive continuity) and with following the troubleshooting guide as per the manual and long nights surfing these forums i then replaced the convection blower...(same result)...and the last step to replace the entire board...ugh!!..and still the same code immediately do i tell if the snap disc switch is tripped or not?....and does it matter which way the wires connect to the snap disc???.so hard to tell and its a little different then what it replaced??..also heard about maybe jumping the stat but im not sure how on this stove???...convection wiring harness???...vacuum switch??..auger feed maybe??....ignition coil??..the possibilities are endless i feel....although i cant see any of those being the culprit since it never even gets to that stage..bought the stove 3 years ago used and it has worked flawlessly up until now so to say its frustrating is an understatement...thanks in advance for any help