need help with KOZI pellet stove!

  • Active since 1995, is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.
Not open for further replies.


New Member
May 15, 2010
Northern Pa
hey there all, need some help here. I recently purchased 2 used KOZI pellet stoves and about 30 feet of pipework and elbows for 800 bucks in hopes i was getting a deal. Not sure how much of a deal i got! One stove was claimed worked and one was not. The stove that was not working was the KOZI baywin model. Not sure what the problem was but first things first....he left it outside for a couple of months so of course it got rained on with pellets inside....thus the pellets expanded and now the auger won't budge. I took the auger motor off and cleaned up what i could but still cannot move the auger itself one bit. Is there some trick to get these augers out? As for the stove that was suppose to work ( a KOZI shop heater, model 120 i believe), the auger is also jammed but it at least makes an attempt to turn it.....not sure how to free these up to clean them? Other than that they both have the blower motors working and both igniters get hot, so that looks positive for me. Any help would be greatly appreciated! So far, i have had very little luck looking for parts or dealers or tech service for these KOZI stoves. I bought the stoves in hopes to repair one and sell it and use one for supplemental heat in my basement when i have company over. I bought a brand new stove last year from lowes, New Englander 1500 sq ft., and installed it myself....worked GREAT all winter long, starting to think i should see if the guy will take the stoves back and i'll just go purchase another new englander!
Welcome baumic,

as for getting the augers out, after you take the auger motor out, try using a pair of vice grips on the auger shaft and start twisting it back & forth. Hopefully, eventually you should be able to "unscrew" the auger back out of the auger flight tube.
Well I don't think anyone else on this forum has a kozi stove besides me. I have the shop heater ( 120) Fortunately I have not had to mess around with my augur. So I can't really help I guess. Hopefully your kozi will produce better heat than mine if you get it fixed. I bought mine used from a dealer and it has poor heat output.
good luck....
thanks for the replies....i see there is a brass fitting on both ends of the auger and i didn't know if there was also a snap ring or something else holding it at the top....i know i can get it out....just did not want to force it....but i think it will need some "gentle" persuasion haha. i have the motor off the baywin stove and it still won't budge. as for the shop model, the set screw holding the motor to the auger is on the bottom side of the tube and can't be accessed....grrrrr.....a last resort i have come up with is to burn up the bloated pellets in the tube with a torch, hopefully turning to ash and freeing up the auger. if i can get one to work, i think i will try to sell them and get my money back. i see on ebay there are refurbished new englander 1500 sq ft. stoves for a good price...i already have one of those for upstairs and could not be happier with it. btw, i use barefoot pellets. very happy with them, in case you have access to them in your area
baumic, do you have the owners manuals for the stoves? Here's Kozi's solution to your problem:

"Occasionally, fuel can become
lodged in the auger and prevent the augers proper operation. Open one
of the side panels and grasp the auger motor. Move the auger motor back
and forth. It may be difficult to move at first but should move relatively
freely. If it will not move, empty the hopper and look for foreign objects
in the auger."

Not much help....pretty much what i said earlier.

BTW, be careful trying to burn the pellets out of the auger.
yeah i have a manual imacman, but thanks for the research! that's about the only info i could find on it also. i will try to get ahold of a kozi dealer again tomorrow and possibly a tech, but so far that seems out of reach. The instruction manual for the stove is quite basic, and for reference more than repair unfortunately. I have tried the move the auger with vise grips but wouldn't budge. Maybe i'll take some pics tomorrow and post them...there is not much room to get a good grip on the auger unless you start drilling pop rivets to the hopper...which i might do haha .....also would be nice to find a parts list with the prices somewhere.....
baumic96 said:
...there is not much room to get a good grip on the auger unless you start drilling pop rivets to the hopper...which i might do haha .....

Not a big deal, as long as you have replacement rivets & gun. Make sure to reseal with silicone if that's how the factory did it.
swelled pellets set up like concrete if they get wet enough then dry, been there done that "it sucks" see if you can visually locate the upper brass fitting that supports the auger (im not familiar with the kozi's and the manual sucks(i googled it already)) anyway .if you cannot see the brass fitting its doubtful that there will be a keeper there(it would have to be accessable to install one), in ESW units there is not and usually i take a screwdriver to pry downward to pull the augerwhen it has swollen pellets in it, be advised this could warp the auger but they shouldnt be too expensive, if you are careful you probably wont hurt it.

here is a link to the kozi homepage, im not sure how helpful it will be in clearing the jam but here it is anyway , look for a Customer service phone number like we have at ESW maybe if they have one they could verify my suspicion on the "keeper" ring's existance. hopefully they can give you some insight. if not , hell , PM me a daytime phone number i see you have one of my units , that makes you one of my customers. if you get nowhere with kozi , drop me that number , i'll give you a buzz and maybe we can figure the thing out. i havent played with their stoves but ive dealt with it in the past with my stoves. i'd be interested in seeing how they do things.

nothing against kozi BTW , by reputation they make a good solid product. im suprised theer arent more kozi owners in here.

even though you are working on kozi's youre still ESW family!
let me know if i can help bro.
i like how stoveguy is willing to help me out with a competitors stove! doing some good guy PR work? :) haha. anyhow thanks for the advice, i got the augers free and clear. I made a halfass attempt to burn the chute that was jammed full of pellets, and did not get very far. I ended up taking the brass fitting off the bottom of the auger and taking a pair of vise grips to the auger and forcing it back and forth. There was no retaining clip on the top of the auger holding it in place, just another brass fitting in which the auger slides into. I did a burn test on both stoves. I was told that the KOZI 120 shop heater that i got was in working condition, which it is! Everything seems to work as it should, but I must say I believe I get MUCH more heat out of my englander 1500 sq. ft. stove. Now I know I was testin outside when it was about 55 degrees out, but still was not real impressed with the heat output...also was very noisy. ( needs a very thorough cleaning ). Anyhow the KOZI Baywin stove I got with the 120 model does not work properly, which I already knew. narrow down what's wrong it......On startup, the auger works, the automatic startin system worked. The exhaust blower works but is quite weak....again more cleaning? After the fire started up it seems to be lackin air.....flames were lazy and dark.....i believe the intake pipe was partially clogged. What does not work properly was the circulation fan....the stove got really hot and the fan would not kick on to disperse the heat through the exhcangers. After quite some time the fan did kick on for about 30 i know the fan works...i believe it kicked on to prevent the stove from my possible fixes are some sort of heat sensor is faulty and not telling the fan to kick on after it gets heated up. another possibility is the control board itself. not sure where i will go from here besides taking the blowers off and cleaning them. i may try swapping parts from my working KOZI stove to the baywin to pinpoint the problem, again thanks for everyones help!

also, after i had the pellets going nice and hot and still no fan on, i was able to hit the power button and the stove would have shut completly off....not a good thing with pellets burning in the pot, it acts like something is not telling the stove to turn the fan on automatically or that there is a fire going....not sure which sensor or component would tell it that, but i think that's whats wrong....
Glad my advice on using the vise grips worked out getting the auger out.

As for the stove convection blower not coming on, the POF switch (proof of fire) may be should be located on the exhaust system near the combustion blower.

My advice is to start taking the stove apart and clean EVERYTHING as far as you possible can. There may be lots of ash built up/caked in places you didn't know existed, but usually as you disassemble the stove, those ash traps will become apparent.

The blowers may just a good cleaning and maybe even some lubrication. Make a 120V test cord out of an old lamp cord so you can connect the blowers after cleaning to see how well they work.

Reassemble and then use the leaf blower method on might get even more ash out (do this procedure outside....LOL).
I am one of the people that actually own a Kozi Baywin...Love it...kept us toasty last winter anyway at first I had a few problems and my dealer wasn't much help so I call Kozi in Canada and talked to Marvin a tech guy he was great. I told him the problem and he explained it. He also gave me a few other dealer in my area try giving them a call they were very helpful!
might want to give it a good "leaf blower" method of cleaning or high pressure air if you have a compressor and an air gun. as for the immediate shutdown , sounds like a "low limit" switch, locate the switch and see if you can jumper it out if its a snapdisk you should be able to if thhis allows you to turn the unit on and then have a shutdown procedure initiate when you turn it off replacement of the snapdisk should solve the problem (note im not familiar with their product line so this is just a guess)
Not open for further replies.