Quadra-Fire Castile not starting up

  • Active since 1995, Hearth.com is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.


New Member
Nov 20, 2020

I created a post on this earlier this morning and came back and can't find the post so I am writing it again. If I am offending someone or not following the rules of this forum, please let me know and I will ask my questions in an appropriate manner.

I have a quadra-fire castille which has sat for over a year due to me having young kids in the house. I recently tried to start it up and the unit did not start or do any activity. I messed with taking the control board out and jiggling it in its mount and the unit came to life but didn't light. I had problems in the past with the igniter and had replaced that so I went and looked and the igniter was not getting hot and further testing with a voltage meter showed that at the start of a cycle it would get 120v for @30 seconds then voltage would stop. Later in the cycle I was getting a orange light which from reading posts here seems to be a thermocouple issue.

I am somewhat concerned that the control board needs to be jiggled to get the unit to turn on and am wondering if that is the sign of the control board going bad or is it the connector to the rest of the wiring harness.

Any suggestions on the most cost effective order of testing / replacing parts would be appreciated.

I ordered a new control box and thermocouple. a co-worker advised getting some 1000 grit sand paper and putting it around a credit card and then inserting it into the slot where the control box goes. I was going to tack on spraying it all down with electrical contact cleaner spray.

I should get the other parts early next week and provide feedback

also - looks like I double posted and my posts need to be approved before being released as I am a newbie here.
You stated in your other thread that you are selling your house. Are you taking the stove with you or selling it separately from the house?

It sounds like it is the connector block getting worn out. Try bending the tabs closed to get pressure on the connection.
I am not keeping the stove, it is going to the next person. I would like to make sure it is running as best as possible prior.

I would agree with you that the connector block is loose but I unfortunately think it is more than that because even if it is connected and has lights on, it won't reliably send power to the ignitor. My thought process is to get the new board in try it out, Hopefully with the new board I can get it to fire up and operate even if I have to manually hold the board in place. I will also follow your advice and try to gently bend the pins in. If that fails, there is a kit for @300 that has a new wiring harness and that would be the next step.
ok - got the new control box in and I set it to the right model on the selector switch and plugged it in and am getting the 6 blinking blue lights the manual calls for a Castile stove yet the ignitor does not light.

I unplugged the ignitor and plugged in my multi meter and I am getting @120 volts for about 15 seconds then I can hear a relay kick and power is turned off.

Is there another safety switch somewhere in the system which would trigger the ignitor to stop receiving power? I've tested continuity on each of the 3 snap disks and they all have continuity. I have tested the vaccum switch and when I open the door it stops feeding pellets.

Something is telling the control board to shut off power to the ignitor, any suggestions?
I made more progress - I had also ordered a new thermocouple and I temporarily plugged that in and miracles never cease, the ignitor got 120v and the voltage stayed on. Ok, next problem get the thermocouple and the whole stove back toegether... yeah that didn't go so well. I saw the bolt for the part holding down the thermocouple and started to unbolt it and promptly snapped it off. I ran the new thermocouple and the added ground wire and put it together as best I could and I was able to get the stove to light. It won't feed pellets beyond the initial light and that may be that I don't have the thermocouple positioned well without its mounting bracket. Hitting reset a couple times, I did get the circulator fan to turn on and generate heat so I think I am most of the way there.

Long story short - if you run into a silly problem like I did, and the ignitor won't keep voltage, replace the thermocouple first.
in the realm of getting the bolt which holds down the burn pot out - is there an easy way to get the shroud off which goes around the bottom of the burn pot, my thought process is that there might be enough of the bolt under that I could get a set of vice grips on it and spin it off, there is no working room with the shroud on.
  • Like
Reactions: Ssyko
The nut underneath is pressed in. Probably easiest to remove it with vicegrips underneath then just use a regular nut to replace it. Drilling out broken bolt would be a PITA.
I just refurbed my Quad this week to make sure it works before it gets cold and took the burn pot out to respray the inside. The bolt was rusted on mine and the pressed-in nut broke off. Afaik, the part is not available directly to most people through HHT. I just used a nut and washer to replace it and works fine. Just take the bolt with you to the hardware store. Make sure you get a washer to go with it. You'll need to get the gasket as well now that you have disturbed it. It's not a regular gasket and apparently the Lynn ones don't last very long (according to reviews) so best to get the OEM if you can.