Ravelli RV100 classic error code 07

Art1 Posted By Art1, Nov 4, 2018 at 2:55 PM

  1. Art1

    Art1
    New Member 2.
    NULL
    

    Nov 4, 2018
    5
    1
    Loc:
    Moravia, New York
    Hi I just got a new RV100 classic. After installing it, I tried to run RDS setup but ran into a problem. The stove fills the fire pot with some pellets then just as the smoke extractor fan and the ignition element turn on, I get an error code "07-Termic" displayed and the stove turns off. The stove is new, never had a fire in it and the thermal sensor tested good. Is there anyone that can help me? The dealer said it will be December before they can look at it. Thanks
     
  2. jerrieric

    jerrieric
    Burning Hunk 2.
    NULL
    

    Jul 7, 2008
    229
    47
    Loc:
    Windham Me
    I bought an rv100c last winter and I had the service guy actually come down and program it correctly for pellet feed a cetera. Installation was free because I paid the price they were asking for it at the store. So I would recommend you have a tech do the initial setup.
     
  3. Pelleting In NJ

    Pelleting In NJ
    Minister of Fire 2.
    NULL
    

    Sep 26, 2011
    528
    92
    Loc:
    Central NJ
    Sounds like the thermocouple (temperature sensor in the exhaust) might be bad, or not connected properly. Find the silver metal braid covered wire, maybe the 2 screw terminal connections to the control board are not tight. Also check that the probe end of the cable is properly inserted into the exhaust pipe (right before the exhaust pipe exits the stove cabinet). The probe just pushes thru an orange gasket, so the probe tip is in the exhaust stream.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Art1

    Art1
    New Member 2.
    NULL
    

    Nov 4, 2018
    5
    1
    Loc:
    Moravia, New York
    I looked at the thermocouple in the exhaust tube. All hooked up, wires in place, and it is sending temperature readings. Service tech coming tomorrow hopefully he can fix it. Thanks
     
  5. Manly

    Manly
    Feeling the Heat 2.
    NULL
    

    Aug 8, 2017
    424
    281
    Loc:
    CT
    Please let us know the outcome. Always trying to learn more about these quirky Ravelli stoves.
     
  6. Art1

    Art1
    New Member 2.
    NULL
    

    Nov 4, 2018
    5
    1
    Loc:
    Moravia, New York
    Here's the latest. Dealer came out and replaced the thermal sensor, stove still will not run [code 07-Termic]. He ordered a new control board, fingers crossed this will fix it. I will let you know.
     
  7. Manly

    Manly
    Feeling the Heat 2.
    NULL
    

    Aug 8, 2017
    424
    281
    Loc:
    CT
    Thanks for the update. Good luck and keep us posted.
     
  8. Art1

    Art1
    New Member 2.
    NULL
    

    Nov 4, 2018
    5
    1
    Loc:
    Moravia, New York
    Dealer replaced control board and the stove works. Glad to finally have it working. Thank you for all the help.
     
    jerrieric likes this.
  9. Manly

    Manly
    Feeling the Heat 2.
    NULL
    

    Aug 8, 2017
    424
    281
    Loc:
    CT
    Good to hear. Hope it stays running for you. So far knock on wood my Francesca has been operating trouble free, but the season is just starting. Didn’t not make it through its first two seasons without replacing parts.
     
  10. jerrieric

    jerrieric
    Burning Hunk 2.
    NULL
    

    Jul 7, 2008
    229
    47
    Loc:
    Windham Me
    Anyone know where to get a vermiculite kit for the rv100c online
     
  11. Manly

    Manly
    Feeling the Heat 2.
    NULL
    

    Aug 8, 2017
    424
    281
    Loc:
    CT
    Give Woodsman Parts a try.
     
  12. jerrieric

    jerrieric
    Burning Hunk 2.
    NULL
    

    Jul 7, 2008
    229
    47
    Loc:
    Windham Me
    Thing that bugs me about woodsman's is they don't have any prices online
     
  13. Manly

    Manly
    Feeling the Heat 2.
    NULL
    

    Aug 8, 2017
    424
    281
    Loc:
    CT
    I have made a couple of purchases over the phone. Very personable folks, and if I recall correctly they will send you prices via email if requested.
     
  14. jerrieric

    jerrieric
    Burning Hunk 2.
    NULL
    

    Jul 7, 2008
    229
    47
    Loc:
    Windham Me
    Yeah but I like to shop on the internet and people that don't have their prices listed irritate me. I can get the vermiculite at my local dealer but I don't need it now so when time comes to get it I will then do the price dance
     
  15. grobinson2

    grobinson2
    Member 2.
    NULL
    

    Apr 15, 2010
    80
    5
    Loc:
    Peach Bottom, PA
    Hey Guys, I know this was from a month or so ago but I am a tech and we are a Ravelli dealer. If you need anything feel free to let me know. We have helped people from ME to WA with the Ravelli line of stoves. Certainly don't know it all but so far I have not run into an issue that we could not solve. Now the older EkoTech line of Ravelli thats another story. :)

    Thanks again,
    Glenn
     
    Bobmarsh likes this.
  16. Pelleting In NJ

    Pelleting In NJ
    Minister of Fire 2.
    NULL
    

    Sep 26, 2011
    528
    92
    Loc:
    Central NJ
    What issues or problems have you seen with the Ecoteck stoves?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. grobinson2

    grobinson2
    Member 2.
    NULL
    

    Apr 15, 2010
    80
    5
    Loc:
    Peach Bottom, PA
    Overall lack of maintenance which of course is not the stoves fault. That said once something fails it is like a wild goose chase finding the issue and then fixing it. The RDS stoves can be problematic as well, (especially the 120 series) but once you know whats going on fixing the issue is much easier.

    Thanks again,
    Glenn
     
  18. Bobmarsh

    Bobmarsh
    New Member 2.
    NULL
    

    Jan 26, 2019
    3
    0
    Loc:
    Northville, MI
     
  19. Bobmarsh

    Bobmarsh
    New Member 2.
    NULL
    

    Jan 26, 2019
    3
    0
    Loc:
    Northville, MI
    I need help! I have a ravelli rv80. I am getting the 07 termic code & air flow sensor code. The air flow sensor code has been there for awhile and has worked fine. I have cleaned the sensor and did nothing. I recently had to replace the auger motor too. Been working fine since auger motor was replaced and now this. The auger will not activate and feed any pellets it shuts down after start up and displays code 07 termic. Its supposed to be below zero all next week. No dealers in my area and called a few places and they dont service them. I will need to fix myself. Any help would be greatly appreciated!!
     
  20. grobinson2

    grobinson2
    Member 2.
    NULL
    

    Apr 15, 2010
    80
    5
    Loc:
    Peach Bottom, PA
    PM me with contact info. I can air mail parts to you but there is a chance you don't need them.
     
  21. Bobmarsh

    Bobmarsh
    New Member 2.
    NULL
    

    Jan 26, 2019
    3
    0
    Loc:
    Northville, MI
    PM Sent, thank you!
     

Share This Page