Ravelli RV80 Display Problems

Ajminny Posted By Ajminny, Nov 8, 2018 at 7:57 AM

  1. Ajminny

    Ajminny
    New Member 2.
    NULL
    

    Nov 8, 2018
    1
    0
    Loc:
    Upstate NY
    Hello Everyone,

    I have an Ravelli RV80 pellet stove, the house came with it. It worked all last season, but towards the end had some firing up issues. No problem, made it thru ... fast forward... cleaned chimney out for the first time this weekend (now I understand the issues!). Cleaning went fine, plugged it back in, turned it on (in the back), heard a fan kick on, but can’t get the display to turn on. Saw it blink blue once, but that was it. I am assuming power is good, because I can hear a fan kick on when I cycle the main power switch. Any ideas? Thanks!
     
  2. jerrieric

    jerrieric
    Member 2.
    NULL
    

    Jul 7, 2008
    70
    1
    Loc:
    Windham Me
    reset switch in the back?
     
  3. ranierom

    ranierom
    New Member 2.
    NULL
    

    Saturday
    1
    0
    Loc:
    Jim Thorpe PA
    OK guys, I just purchased a Ravelli RV80 and I am wanting to fire this thing up. Any assistance would be greatly appreciated. The store that sold it to me said he'll be able to come this Monday or Tuesday. Was looking for any advice on how to start her up.
     
  4. Pelleting In NJ

    Pelleting In NJ
    Feeling the Heat 2.
    NULL
    

    Sep 26, 2011
    496
    80
    Loc:
    Central NJ
    Make sure that the ribbon cable connectors are fully seated to the LCD display board, and the other end on the control board.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...

Share This Page