1. Welcome Hearth.com Guests and Visitors - Please enjoy our forums!
    Hearth.com GOLD Sponsors who help bring the site content to you:
    Hearthstone Soapstone and Cast-Iron stoves( Wood, Gas or Pellet Stoves and Inserts)
    Caluwe - Passion for Fire and Water ( Pellet and Wood Hydronic and Space Heating)

Avalon Pellet Stove Problem

Post in 'The Hearth Room - Wood Stoves and Fireplaces' started by Yellowstone Yeti, Mar 20, 2006.

Thread Status:
Not open for further replies.
  1. Yellowstone Yeti

    Yellowstone Yeti New Member

    Joined:
    Mar 20, 2006
    Messages:
    1
    I have an older Avalon 900 PS pellet stove. Lately when it is shutting down, it cycles the convection fan on and off when it is cool. It eventually shuts down, but hasn't done this in the past. I can hear a faint buzzing sound when the motor is in this OFF cycle during shutdown. The motor will start back up, only to shut down and buzz after a few moments. It does this cycling for anywhere from 0-15 minutes. This cycling will also produce static through any speakers-computer, home theater, etc. so I am a little concerned that it may be drawing a lot of current. I have hotwired the fan and it seems to run fine. I haven't had a chance to check the convection snap disk yet. The manual says to heat it and see if continuity is present when over 120. It seems like an inexact test at best? Any other suggestions to try? Any help is appreciated. Thanks

    Helpful Sponsor Ads!





  2. begreen

    begreen Mooderator Staff Member

    Joined:
    Nov 18, 2005
    Messages:
    47,020
    Loc:
    South Puget Sound, WA
    You probably are on the right track. I'd replace the low heat convection fan snap disk. It sounds like it's losing its 'snap'.
Thread Status:
Not open for further replies.

Share This Page