1. Welcome Hearth.com Guests and Visitors - Please enjoy our forums!
    Hearth.com GOLD Sponsors who help bring the site content to you:
    Hearthstone Soapstone and Cast-Iron stoves( Wood, Gas or Pellet Stoves and Inserts)
    Caluwe - Passion for Fire and Water ( Pellet and Wood Hydronic and Space Heating)

In Progress slow site

Post in 'New Forum Hints and your Questions & Suggestions!' started by flyingcow, Mar 25, 2012.

  1. flyingcow

    flyingcow Minister of Fire

    Joined:
    Jun 4, 2008
    Messages:
    2,270
    Loc:
    northern-half of maine
    I know you guys have got bugs to work out, but this is really a slow site now. I can open up another page and go to multiple sites and keep surfing.

    Helpful Sponsor Ads!





  2. BrotherBart

    BrotherBart Hearth.com LLC Mid-Atlantic Division Staff Member

    Joined:
    Nov 18, 2005
    Messages:
    27,295
    Loc:
    Northern Virginia
    Only the second person to say that. This thing flies for me and I am on an old computer. Several people have commented about how much faster than the old forum it is.
  3. webbie

    webbie Seasoned Moderator Staff Member

    Joined:
    Nov 17, 2005
    Messages:
    12,255
    Loc:
    Western Mass.
    Looking at the speedometer on the server - we are at about idle - which means, in technical terms, something else is wrong between you and our server (likely).....

    We will tune up for speed over the slow season, but as of now the thing is not being taxed at all on this end....
  4. flyingcow

    flyingcow Minister of Fire

    Joined:
    Jun 4, 2008
    Messages:
    2,270
    Loc:
    northern-half of maine
    well thats odd. But have been using for the last few days, for me not working fast at all. See how this works out.
  5. flyingcow

    flyingcow Minister of Fire

    Joined:
    Jun 4, 2008
    Messages:
    2,270
    Loc:
    northern-half of maine
    not doubting you, but when i open up another page i can run with all the other sites. It isn't because i am a registered republican is it? just kidding. check in later. Thanks for the responses.
  6. Jack Straw

    Jack Straw Minister of Fire

    Joined:
    Dec 22, 2008
    Messages:
    2,161
    Loc:
    Schoharie County, N Y
    I have 3 computers, this site is extremely fast w/the MacBook Pro, a little slower on my old Windows based laptop, and very slow w/my antique work computer which has windows 2000. Can't drive fast in a Model A.
  7. SmokeyTheBear

    SmokeyTheBear Minister of Fire

    Joined:
    Nov 10, 2008
    Messages:
    12,061
    Loc:
    Standish, ME
    Craig, what is your mix of self served ads to Google syndicated ones ... I've seen Google ads really slow down page loads at times. Likewise images from off site servers can do the same.
  8. SmokeyTheBear

    SmokeyTheBear Minister of Fire

    Joined:
    Nov 10, 2008
    Messages:
    12,061
    Loc:
    Standish, ME
    flyingcow, how is your browsers cache setup? There are a number of scripts that have to be downloaded and if your browser is setup to not cache then you are downloading them more than is needed.
  9. webbie

    webbie Seasoned Moderator Staff Member

    Joined:
    Nov 17, 2005
    Messages:
    12,255
    Loc:
    Western Mass.
    You are correct, Smokey, that google ads definitely slow the site down - in terms of the total page rendering. But it's only an extra second or so....
    Modern web sites make extensive use of certain code snippets - translation, a modern browser and OS will work MUCH better!
  10. SmokeyTheBear

    SmokeyTheBear Minister of Fire

    Joined:
    Nov 10, 2008
    Messages:
    12,061
    Loc:
    Standish, ME
    Craig there are also a lot of additional DNS inquires that take place with images coming from other sites, to really nail down what the site user sees you have to be at their location on their system with some kind of recording data scope or protocol analyzer. I have such a utility on my system. As for running with the latest and greatest, that can be a double bitted ax experience.

    I run Firefox 11.0 and run on Linux 3.1.9-1.4 which is one of the latest stable versions.
  11. LLigetfa

    LLigetfa Minister of Fire

    Joined:
    Nov 9, 2008
    Messages:
    7,343
    Loc:
    NW Ontario
    You might try using Google (IP addresses 8.8.8.8 and 8.8.4.4) as your DNS servers.
  12. webbie

    webbie Seasoned Moderator Staff Member

    Joined:
    Nov 17, 2005
    Messages:
    12,255
    Loc:
    Western Mass.
    Good hint for everyone! I use these whenever possible....

    I think a lot of things are at play here - our server is definitely not running "hot".....it's loafing along. But there are probably a lot of tweaks we can do as the days go by.
  13. webbie

    webbie Seasoned Moderator Staff Member

    Joined:
    Nov 17, 2005
    Messages:
    12,255
    Loc:
    Western Mass.
    Strange - I am getting medium to long load times from certain test locations......
    So I think the complaint is valid.....

    On my 2-3 year old macs it is very fast - 2 seconds or less per page...

    I've got some ideas.....will work on them.....
  14. St_Earl

    St_Earl Minister of Fire

    Joined:
    Sep 9, 2011
    Messages:
    1,089
    Loc:
    millinocket, north central maine
    just by way of feedback, i get very fast response part of the time. and then it will be slow right after. just for instance, i clicked "home' and it snapped right to the home page. but then it was slow when i clicked to enter this forum.
    i love the new look. and just want to thank you for the great site.
  15. webbie

    webbie Seasoned Moderator Staff Member

    Joined:
    Nov 17, 2005
    Messages:
    12,255
    Loc:
    Western Mass.
    There is always a certain amount of caching which occurs - that is, when you go to a place the second time it will be faster. I changed some settings......let me know if it seems to load faster at all.

    Make sure you have some cache setup on your browser prefs also.
  16. firefighterjake

    firefighterjake Minister of Fire

    Joined:
    Jul 22, 2008
    Messages:
    14,859
    Loc:
    Unity/Bangor, Maine
    Flying Cow . . . have you checked in with your local Internet Service Provider where you are . . . perhaps the guinea pig on the wheel providing power to the system died and has been replaced with a slower guinea pig? :)
  17. Backwoods Savage

    Backwoods Savage Minister of Fire

    Joined:
    Feb 14, 2007
    Messages:
    27,816
    Loc:
    Michigan
    Today is the first time I've experienced some problems. Three times it did not want to load a page. I finally switched to something else then came back and all was well.
  18. flyingcow

    flyingcow Minister of Fire

    Joined:
    Jun 4, 2008
    Messages:
    2,270
    Loc:
    northern-half of maine
    My windmill is defiantly running hot today, not the hamster. Majority of the time when i load Hearth i open up another page and surf all the other places i go, like sledmaine. All my other sites load up pretty quick as usual. just hearth is slow(30 secs to a min). No biggie, takes a bit to get the bugs out. I'm 99.9% sure it's not this end.
  19. Gasifier

    Gasifier Minister of Fire

    Joined:
    Apr 25, 2011
    Messages:
    3,135
    Loc:
    St. Lawrence River Valley, N.Y.
    Did the alerts stop working?
  20. flyingcow

    flyingcow Minister of Fire

    Joined:
    Jun 4, 2008
    Messages:
    2,270
    Loc:
    northern-half of maine
    Sped up for a bit, than just slowed down.
  21. flyingcow

    flyingcow Minister of Fire

    Joined:
    Jun 4, 2008
    Messages:
    2,270
    Loc:
    northern-half of maine
    Sped up for a bit, than just slowed down.
  22. webbie

    webbie Seasoned Moderator Staff Member

    Joined:
    Nov 17, 2005
    Messages:
    12,255
    Loc:
    Western Mass.
    Strange - Google webmaster tools shows about 3.5 second average per page - with the longest being less than 7 seconds.

    They are measuring thousands of data points.

    Flying, what OS, computer and browser are you using?
  23. Gasifier

    Gasifier Minister of Fire

    Joined:
    Apr 25, 2011
    Messages:
    3,135
    Loc:
    St. Lawrence River Valley, N.Y.
    Now the alerts are working again. Strange.
  24. flyingcow

    flyingcow Minister of Fire

    Joined:
    Jun 4, 2008
    Messages:
    2,270
    Loc:
    northern-half of maine

    Firefox, windows based unit a couple of yr old computer. My ISP can only give me just under a mbyte for download speed. When i go to hearth, i open a another page and surf, FB, News websites, etc. some fairly big sites and they load pretty quick. A few seconds, and i keep flipping back to hearth. No joke, it's a minute sometimes loading. Even after i get in and i flip from topic to topic it's slow. The main forums are faster. No biggie.
  25. flyingcow

    flyingcow Minister of Fire

    Joined:
    Jun 4, 2008
    Messages:
    2,270
    Loc:
    northern-half of maine
    Also, my time stamp is off

Share This Page