Ashley Ap5710 combustion blower not coming on

  • Active since 1995, is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.


New Member
Nov 1, 2023
New York
My Ashley ap5710 stopped working at the end of last year. I waited til now to buy parts and try it again. I changed the combustion blower and the pof I fully cleaned out the stove and the pipes. I noticed the fuse 7.5a was blown (it was blown before changing parts I just wasn’t sure til I pulled it out) I tested the volts coming to the combustion blower at 120. The air switch at 5 volts. I changed the 7.5a fuse and it had the exhaust blower working but still not the combustion blower. The stove starts to load pellets into the pot but shuts off with an e2 code. I changed the air switch and may have hooked it wrong as it because the 7.5 fuse blew again. I switched the fuse again and still only the exhaust blower comes on. I checked the wires and don’t see any issues on them. I have no clue what to check next.
I have the manual and tried everything listed for those issues. I changed the air flow switch and nothing the control board is sending 5volts changed the combustion blower nothing. The board is sending 120 v. Even hooked the old blower up still nothing. I have used this stove for about 4 years it’s cleaned out and parts have been replaced changing the fuse made the exhaust blower work