Breckwell keeps blowing fuse

  • Active since 1995, is THE place on the internet for free information and advice about wood stoves, pellet stoves and other energy saving equipment.

    We strive to provide opinions, articles, discussions and history related to Hearth Products and in a more general sense, energy issues.

    We promote the EFFICIENT, RESPONSIBLE, CLEAN and SAFE use of all fuels, whether renewable or fossil.


Feb 13, 2021
Hello, I haven’t been on for awhile. I’m fairly capable and doing my own repairs but this one has me a bit stumped. So the wife and kids let the pellets run out, upon refilling the pellets and going to turn it back on, no lights came on. When I got home I checked the fuse on the back of the, it was blown. Replaced the fuse it immediately blew again, so I took all the electrical components and unplugged them inside the pellet stove. Plugged the control board back in, fuse didn’t blow. Unplugging it back in each time I plugged the components back in and came to find out the auger being plugged in was blowing the fuse.

I contacted the dealer I bought it from few years ago and suggested I make pigtails and plug a extension cord directing to auger motor and if it rotates and doesn’t smoke it’s most likely not the issue and probably the control board. So I did so and let it run for 2-3minutes. Ran fine, no smoke and fed pellets. Plugged it in and it blows fuse again. Sooo before I spend 350+ on a non refundable control board. Are there any other ways to check the motor?

It’s a 4 year old breckwell big e 1000

Thank you for your time
that is a interesting one should have been no reason for the board to fail just running out of pellets, heck the fuse does not even blow when the auger jambs up and shears the pin off and you would think that's where it should blow. Can you see any signs of failure on the board? The only think i could think of here is the stove had a slight jamb when it was pulling the last of the pellets and fines hurting the board, probably pushed itself through when you hooked it up direct..

I had my board fail last year when my room fan seized up but it did not fail completely. I changed every sensor and blower in the unit and on startup when the fans kicked in the fans would surge until it reached temp and then everything would run as normal. Once i replaced the board everything ran better than it ever has.. And yet it still did not blow a fuse..

As much as you do not want to hear it i think a board replacement is in your future, keep the old board and send it out for repairs and keep it as a spare.. At least your not in canada were the board is 2x as much.
This is a long shot but did you try bypassing your hopper switch and inspecting the hopper switch , red/yellow and purple wire for a bare spot.
Breckwell keeps blowing fuse
Ya, 4 year old stove. I’ve replaced the convection fan yearly from the bearings going out. The exhaust fan seized up between spring and fall of this year. Not been much of a fan of the pellet stoves
closed so auger will spin? If so it does have one of those
Correct as shown in wire diagram, I am sure that some versions of the Big E do not have hopper switches as zrock knows his pellets stoves. The reason I mention it is because when any switch goes bad they do weird things. Some times that stop working, work when they want to, create shorts and throw codes that do not make sense. Its a long shot that it is the problem but should be checked along with the wiring before you spend money on a new board. Also check the molex plug that attaches to board and the pins on the board were the main plug attaches especially were the red/yellow wire is.
Interesting... mine does not have one even though the instructions said it does... always thought it was a typo in the instructions
  • Like
Reactions: ARC
Ya mine is on the left side of the lid, and wires look to be all intact and pins seem to be correct, starting to feel like it’s time to go back to a wood stove. This thing has been nothing but a night mate
Mine has been rock solid except for last year taking out the board and I'll take partial responcibility for that.. whoever replaced the room fan before I owned it put the motor in upside down so I never seen the oil ports.. it over 5 years I have replaced every part once but kept most of the parts from last year as they were not actually bad... for what I save in heating I'm still way ahead..

I think once u get the gremlins out of it like mine it will be a good stove
wires look to be all intact and pins seem to be correct

Did you try bypassing/jumping the switch take wires off hopper switch, connect them together with jumper wire or paper clip, tape them so the do not touch stove, try starting stove. Try after you inspect the purple and red/yellow wires for bare spots and the molex plug for bent pins.

Breckwell keeps blowing fuse
The only way the hopper switch is going to assist in blowing the fuse is if it has rubbed through somewhere and is shorting out.. Just out of curiosity did you just try plugging the auger into the board by itself?
The only way the hopper switch is going to assist in blowing the fuse is if it has rubbed through somewhere and is shorting out
Correct if its broken, it does have a metal plunger and a metal rivet and the electrical spades are close to the sidewall, wires go through the hopper wall could be rubbed there. Can't hurt to check.

Breckwell keeps blowing fuse
So this is the route of which I singled it out. Wife calls me on my way home from Alaska saying the pellet stove won’t turn on and no lights are on the display. I said swap plugs and then verify that the plug house power by plugging in something like a vacuum or a phone charger and making sure it works. It had power.
When I got home I tore the side panel off and checked the fuse and it was indeed blown, so I went to the hardware store and bought 3-4 fuses. When I got home I tried nothing different and plugs it all back in and popped the second the prongs made contact with the outlet. So I unplugged all the electrical and plugged it back in and didn’t pop. I plugged the hardest to reach plugs which was the auger. Tried it again and it popped. Unplugged the the auger and plugged everything else back in and put power to it and fuse stayed.

I contacted my dealer that is also the repair tech and he said it’s very seldom it’s ever the auger and to make pigtails and plug the auger in directly to the outlet. So I did that and let it run for a few minutes cause he said if it smokes than a good sign it’s bad. It seemed to be in good working order. And not wanting to bother him on the weekend anymore I came here. I’ve inspected the wires for rubbing and being bare. also with the confidence in the group I ordered a new board yesterday from earth sense for 350$.
  • Like
Reactions: stovelark and ARC
Unfortunately, the new control board did not fix the issue. I’m going to pull the auger and run some different tests on it this weekend
  • Like
Reactions: ARC
Can you try unplugging both wires on the igniter it shares the neutral with the auger and is the biggest power draw on the stove. I know normally the auger starts and then the igniter starts but wondering if it is shorted. Did you use igniter when you direct powered the auger? Try unplugging white wire from both blowers and igniter? When you tested components before did you unplug just the hot wire or did you unplug both wires?

Probably another stupid question but are you using the correct fuse 285 P 5A 125V or 5A 125V: C-E-046-N? I know stupid question because the new board probably had correct fuse already installed but I had to ask.
Last edited:
when you test the auger again put a inline fuse in your wire when you direct wire it the same size as what is in your board. If it pops you have found your issue, im suspecting when you tested it the first time the house breaker is way to large to trip and the auger may be pulling more amps and have a internal issue that really is not showing up without a fuse inline..

Sucks that the board was not the issue after that expense, but on the bright side you now have a spare for when it does fail and it probably will fail at some point.
  • Like
Reactions: ARC
when you test the auger again put a inline fuse in your wire when you direct wire it the same size as what is in your board. If it pops you have found your issue, im suspecting when you tested it the first time the house breaker is way to large to trip and the auger may be pulling more amps
5 amp fuse compared to 15 amp breaker big difference.
I am using the 5a 125v fuses. When I tested it I unplugged all wires from the auger and made little pigtails to hook to negative and positive and plugged it directly into an extension. And honestly I never thought of the igniter, that would make a lot more sense that it was that cause when the fuse blows it’s immediate, and a lot more brighter of a flash than id assume. I might test that. I like the idea of using an online fuse to test it. Thanks a lot guys. I got a project to finish today for the wife and than I’ll toy with it.. luckily it’s end of the season the cadet wall heaters are more than enough to heater the house
  • Like
Reactions: ARC
I found in many cases when the igniter dies it shorts out causing the fuse on the board to blow. The igniter usually does not short out but when it does, it blows the board fuse and sometimes damages the board. I recently worked on a Regency GF55 where that happened and unfortunately it cooked the triac on the circuit board. Luckily everything else worked so the stove could be lit manually until I got a new panel to put in. So unplug the igniter and test it. A ohm meter should read about 50 ohms if it is good. :)
The old board had a 5 amp fuse with the zig zag filiment which was designed for automotive use in a high vibration environment and sometimes they do not blow when they should. The new updated board had the straight thin wire filiment like it should for a pellet stove. However I added an inline fuse holder from Home Depot with an AGC 4 amp fast blow fuse so if this happens again the 4 amp fuse will blow and the stove can still be started with hand sanitizer by doing the manual light. :) Rememberohms law E=I*R so for 120 VAC and R is 50 ohms the normal current draw is less than 4.0 amps. :)
That is my 2 cents.
Last edited:
Igniter is at 49.2 ohms
That maybe good. You can also attach a cord and plug it into the wall.
That means you may have a short somewhere else. The next thing I would do is plug 🔌 each motor into the wall after the igniter to make sure they are working properly. The best test is to also attach an amp clamp to one of the AC wires and measure the current draw.

Breckwell keeps blowing fuse